Closed Bug 1166117 Opened 5 years ago Closed 4 years ago

[SMS] The word contacts appears in the search bar when adding a contact to a SMS

Categories

(Firefox OS Graveyard :: Gaia::System, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:2.5+, b2g-v2.2 unaffected, b2g-master affected)

RESOLVED WORKSFORME
blocking-b2g 2.5+
Tracking Status
b2g-v2.2 --- unaffected
b2g-master --- affected

People

(Reporter: KTucker, Unassigned)

Details

(Keywords: regression, Whiteboard: [3.0-Daily-Testing],[systemsfe])

Attachments

(2 files)

Description:
When adding a contact to the "To:" field of a message, the user will notice the word "Contacts" appears in the search bar. This could confuse the end user since the search bar doesn't actually search the user's saved contacts. Also, in other apps, the search bar always has the text "Search the web".

Repro Steps:
1) Update a Flame to 20150518010206
2) Tap on the "Messaging" app.
3) Tap on the "Compose" icon.
4) Tap on the "+" icon in the "To:" field.
5) Observe the search bar in the upper left corner of the screen.

Actual:
The text "Contacts" can be seen the search bar.

Expected:
To be consistent with other apps, the text should say "Search the web".

Environmental Variables:
Device: Flame 3.0
Build ID: 20150518010206
Gaia: afea16de7a76c3b6d15c35fb4c37bac71c8ddc6a
Gecko: 35918b0441b4
Gonk: 040bb1e9ac8a5b6dd756fdd696aa37a8868b5c67
Version: 41.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:41.0) Gecko/41.0 Firefox/41.0

Repro frequency: 5/5 100%
See attached: screenshot
Whiteboard: [3.0-Daily-Testing],
This issue does not occur on the Flame 2.2

The search bar does not appear when adding a contact to the "To:" field of a SMS.

Environmental Variables:
Device: Flame 2.2 (Full Flash)(KK)(319mb)
BuildID: 20150517162505
Gaia: f73891b8fcc5f34de81868640754f7cc331fa709
Gecko: 8785a53b8d6e
Gonk: bd9cb3af2a0354577a6903917bc826489050b40d
Version: 37.0 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
This is happening somewhere in the System app.
Component: Gaia::SMS → Gaia::System
Whiteboard: [3.0-Daily-Testing], → [3.0-Daily-Testing],[systemsfe]
blocking-b2g: --- → 3.0+
QA Contact: ktucker
B2G Inbound

Last Working
Device: Flame 3.0
BuildID: 20150514032157
Gaia: 52edb910451301d2e7ac29a28c486c888e65eb3a
Gecko: 060219a679d0
Version: 41.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:41.0) Gecko/41.0 Firefox/41.0

First Broken
Device: Flame 3.0
BuildID: 20150514040454
Gaia: c5b3aa4fc662d961eba79ef24d1378a243109e29
Gecko: 4ed00abd04f0
Version: 41.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:41.0) Gecko/41.0 Firefox/41.0

Last Working Gaia First Broken Gecko: Issue does NOT reproduce
Gaia: 52edb910451301d2e7ac29a28c486c888e65eb3a
Gecko: 4ed00abd04f0

First Broken Gaia Last Working Gecko: Issue DOES reproduce
Gaia: c5b3aa4fc662d961eba79ef24d1378a243109e29
Gecko: 060219a679d0

Gaia pushlog:
https://github.com/mozilla-b2g/gaia/compare/52edb910451301d2e7ac29a28c486c888e65eb3a...c5b3aa4fc662d961eba79ef24d1378a243109e29

This looks to have been caused by bug 1010216
Oleg, can you take a look at this please? This might have been caused by the landing for bug 1010216.
Blocks: 1010216
QA Whiteboard: [QAnalyst-Triage+]
Flags: needinfo?(azasypkin)
Mmm, I'm highly doubt that it may be related to any Messages-only patch, it's definitely System/Gecko issue. Looking at push log, I think it may be related to bug 1160915.

Kevin does this issue sound familiar to you?
No longer blocks: 1010216
Flags: needinfo?(azasypkin) → needinfo?(kgrandon)
We can probably check Email app and see if it has the same issue as well.
I had the same suspicion but bug 1160915 is backed out on master. The backout happened around the same time this bug was filed. Can QA check if this bug still shows up on master?
Keywords: qawanted
Yup, this is most likely resolved since bug 1160915 is backed out.
Flags: needinfo?(kgrandon)
(In reply to Gregor Wagner [:gwagner] from comment #7)
> I had the same suspicion but bug 1160915 is backed out on master. The
> backout happened around the same time this bug was filed. Can QA check if
> this bug still shows up on master?

Hi Gregor,
On latest build of Flame 3.0, the search bar does not appear when adding a contact to the "To:" field of a SMS. (And the search bar also doesn't appear when adding a contact to "To:" field of a E-mail.)
See attachment: Flame3.0_screenshot.png

Device: Flame 3.0
Build ID               20150524160204
Gaia Revision          5bcc08a732163087999251b523e3643db397412c
Gaia Date              2015-05-24 14:44:40
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/b6623a27fa64
Gecko Version          41.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150524.192425
Firmware Date          Sun May 24 19:24:36 EDT 2015
Bootloader             L1TC000118D0

Thanks!
Keywords: qawanted
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.