Moving e-mail to trash, then Undo, leaves a copy of that e-mail in trash

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
3 years ago
9 months ago

People

(Reporter: m.ostrowski, Unassigned)

Tracking

38 Branch

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [dupeme?])

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (X11; Fedora; Linux x86_64; rv:38.0) Gecko/20100101 Firefox/38.0
Build ID: 20150511091338

Steps to reproduce:

To reproduce choose e-mail from any folder, and move it to trash (by pressing Delete). After that, cancel last event (by pressing control+z). E-mail will come back, but when you check trash folder, you will find a copy of this e-mail. When you do it several times (del->ctrl+z), several copies of this e-mail will appear in trash folder. This bug appear in TB 38b5 and TB 31.7.0
When you cancel last event too fast, TB will not move e-mail to trash fast enough, so before cancelling event wait a second or two.



Expected results:

When cancelling "move to trash" event, e-mail should be moved back instead of copied back.

Updated

3 years ago
Summary: Moving e-mail to trash and cancelling last event leaves a copy of that e-mail in trash → Moving e-mail to trash, then Undo, leaves a copy of that e-mail in trash
Whiteboard: [dupeme?]
(Reporter)

Comment 1

3 years ago
In Thunderbird 38.1.0 this bug occurs for archiving (shortcut 'a') and moving to trash (shortcut 'del').
To reproduce:
choose an e-mail.
press a
press ctrl+z
press del for that e-mail
press ctrl+z
result: now you have 3 copies of the e-mail:
one in inbox, second in archie, third in trash.

Comment 2

9 months ago
Michal, does this still reproduce for you when using a current version?

(I'd see this a long time ago, but not recently)
Flags: needinfo?(m.ostrowski)
Whiteboard: [dupeme?] → [closeme 2018-01-20][dupeme?]

Updated

9 months ago
See Also: → bug 786155
(Reporter)

Comment 3

9 months ago
It seems to be fixed. It's working as expected for a and ctrl+z, del and ctrl+z for single post and multi selected posts.
Flags: needinfo?(m.ostrowski)

Updated

9 months ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 months ago
Resolution: --- → WORKSFORME
Whiteboard: [closeme 2018-01-20][dupeme?] → [dupeme?]
You need to log in before you can comment on or make changes to this bug.