Closed Bug 1166202 Opened 5 years ago Closed 5 years ago

[RTL][Browser]The web title in transform view is truncated at wrong side.

Categories

(Firefox OS Graveyard :: Gaia::System::Window Mgmt, defect, P3)

ARM
Gonk (Firefox OS)
defect

Tracking

(b2g-v2.2 affected, b2g-master affected)

RESOLVED FIXED
Tracking Status
b2g-v2.2 --- affected
b2g-master --- affected

People

(Reporter: lulu.tian, Assigned: durwasa.chakraborty, Mentored)

References

Details

(Keywords: polish, Whiteboard: [2.2-nexus-5-l][lang=js][good first bug])

Attachments

(3 files)

[1.Description]:
[RTL][Flame v2.2&v3.0][Nexus 5 2.2&3.0][Browser]When back to Browser app via slide the edge of screen, the web title in transform view is truncated at left side of LTR text.
See attachment:Web title in transform view.png

[2.Testing Steps]: 
Prerequisite: Set system language as Arabic and connect network.
1. Launch Browser.
2. Go to Youtube and play a video that has long LTR name.
3. Pull down the notification bar and tap Settings icon.
4. Slide from left edge to right.

[3.Expected Result]: 
4. It will back to Browser app and the web title in transform view should be truncated at right side of LTR text.

[4.Actual Result]: 
4. It backs to Browser app but the web title in transform view is truncated at left side of LTR text.

[5.Reproduction build]: 
Device: Flame 2.2 (affected)
Build ID               20150518162501
Gaia Revision          5212c658a651e04d6d84dfc1bce06b499c0d0d96
Gaia Date              2015-05-18 12:10:52
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/9e9e0d0f45f0
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150518.211834
Firmware Date          Mon May 18 21:18:49 EDT 2015
Bootloader             L1TC000118D0

Device: Flame 3.0 (affected)
Build ID               20150518010206
Gaia Revision          afea16de7a76c3b6d15c35fb4c37bac71c8ddc6a
Gaia Date              2015-05-17 03:33:40
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/35918b0441b4
Gecko Version          41.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150518.042019
Firmware Date          Mon May 18 04:20:30 EDT 2015
Bootloader             L1TC000118D0

Device: Nexus 5 2.2 (affected)
Build ID               20150518002503
Gaia Revision          f73891b8fcc5f34de81868640754f7cc331fa709
Gaia Date              2015-05-17 21:36:27
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/8785a53b8d6e
Gecko Version          37.0
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150518.041439
Firmware Date          Mon May 18 04:15:05 EDT 2015
Bootloader             HHZ12f

Device: Nexus 5 3.0 (affected)
Build ID               20150518010206
Gaia Revision          afea16de7a76c3b6d15c35fb4c37bac71c8ddc6a
Gaia Date              2015-05-17 03:33:40
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/35918b0441b4
Gecko Version          41.0a1
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150518.043911
Firmware Date          Mon May 18 04:39:27 EDT 2015
Bootloader             HHZ12f

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
Free Test
QA Whiteboard: [rtl-impact]
Triage: P3
Priority: -- → P3
Component: Gaia::Browser → Gaia::System::Window Mgmt
Keywords: polish
I believe thats the edge gesture overlay. Putting on Etiennes backlog.
Flags: needinfo?(etienne)
The template leaves here [1].

And it could certainly benefit from some dir=auto magic :) [2]

[1] https://github.com/mozilla-b2g/gaia/blob/b908638a81f38f9a5c58a2c462b5d89620ba25c7/apps/system/js/app_window.js#L596
[2] https://developer.mozilla.org/en-US/docs/Web/HTML/Global_attributes/dir
Mentor: etienne
Flags: needinfo?(etienne)
Whiteboard: [2.2-nexus-5-l] → [2.2-nexus-5-l][lang=js][good first bug]
Attached image AriesKK_v2.5.png
This issue can be reproduced on latest AriesKK v2.5 build by the same STR in comment 0.
Actual Result: 
It backs to Browser app but the web title in transform view is truncated at left side of LTR text.

See attachment:AriesKK_v2.5.png.
Reproducing rate:10/10

Device: AriesKK v2.5 build
Build ID               20150812230643
Gaia Revision          52f3ea58df38e5427f6afeb636bc6ad01d24022f
Gaia Date              2015-08-12 16:40:43
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/7649ffe28b67aa2dad0f67ea01500c0ff91b2bac
Gecko Version          43.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20150812.222959
Firmware Date          Wed Aug 12 22:30:07 UTC 2015
Bootloader             s1
Blocks: 1181921
QA Whiteboard: [rtl-impact] → [rtl-impact][MGSEI-Triage+]
I am absolutely new to opensource and I like to get things started. I haven't coded much in JavaScript but I would like to dedicate as much of my time as possible to be a part of this wonderful fraternity. I contacted Julien Wajsberg and got the reference of this bug ie 1166202. Can you please assign me the bug and mentor me regarding the same?
I am absolutely new to opensource and I like to get things started. I haven't coded much in JavaScript but I would like to dedicate as much of my time as possible to be a part of this wonderful fraternity. I contacted Julien Wajsberg and got the reference of this bug ie 1166202. Can you please assign me the bug and mentor me regarding the same?
Assignee: nobody → durwasa.chakraborty
Comment on attachment 8656454 [details] [review]
[gaia] durwasa-chakraborty:my-code-fix2 > mozilla-b2g:master

Finally there! Congrats!

Already flagging this as r+, we'll need a green try build to land it. And currently it looks like there's an intermittent, but that's just another learning opportunity :)
I'll email you the details on how to rebase and trigger a new try.
Attachment #8656454 - Flags: review+
https://github.com/mozilla-b2g/gaia/commit/d5e1a4414cb99c36cfe2da9949e52dbfa6fce963

\o/
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.