[First Time Experience]In FTU, the "Connecting..." status is not displayed, when we input a correct password to connect a WiFi.

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
4 years ago
9 months ago

People

(Reporter: yi.zou, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.2 affected, b2g-master affected)

Details

(Whiteboard: [2.2-nexus-5-l][flame-l-testing-needed])

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
Created attachment 8607434 [details]
logcat002.txt

[1.Description]:
[Nexus5 v2.2&v3.0]In FTU, the "Connecting..." status is not displayed, when we input a correct password to connect a WiFi after connecting another Wifi with wrong password 2/3 times.
Occur Time: 16:23
Attachment: logcat002.txt,VID_0002.mp4

[2.Testing Steps]: 
1.Launch the settings app.
2.Tap the Developer button.
3.Tap the Launch First Time Use button.
4.Tap the Next button to connect wifi.
5.Choose a WiFi,but input a wrong password twice or three times.
6.Wait until the connecting status disappears.
7.Choose another WiFi and input the correct password.

[3.Expected Result]: 
7.We should see that the WiFi is connecting and then the WiFi connected.

[4.Actual Result]: 
7.We can't see the wifi is connecting.

[5.Reproduction build]: 
Device: Flame 2.2 (unaffected)
Build ID               20150518162501
Gaia Revision          5212c658a651e04d6d84dfc1bce06b499c0d0d96
Gaia Date              2015-05-18 12:10:52
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/9e9e0d0f45f0
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150518.211109
Firmware Date          Mon May 18 21:11:21 EDT 2015
Bootloader             L1TC000118D0

Device: Flame 3.0 (unaffected)
Build ID               20150518010206
Gaia Revision          afea16de7a76c3b6d15c35fb4c37bac71c8ddc6a
Gaia Date              2015-05-17 03:33:40
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/35918b0441b4
Gecko Version          41.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150518.042019
Firmware Date          Mon May 18 04:20:30 EDT 2015
Bootloader             L1TC000118D0

Device: Nexus 5 2.2 (affected)
Build ID               20150518002503
Gaia Revision          f73891b8fcc5f34de81868640754f7cc331fa709
Gaia Date              2015-05-17 21:36:27
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/8785a53b8d6e
Gecko Version          37.0
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150518.041439
Firmware Date          Mon May 18 04:15:05 EDT 2015
Bootloader             HHZ12f

Device: Nexus 5 3.0 (affected)
Build ID               20150518010206
Gaia Revision          afea16de7a76c3b6d15c35fb4c37bac71c8ddc6a
Gaia Date              2015-05-17 03:33:40
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/35918b0441b4
Gecko Version          41.0a1
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150518.043911
Firmware Date          Mon May 18 04:39:27 EDT 2015
Bootloader             HHZ12f

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
Free Test
[7.Note]:
This issue doesn't  exist on Flame v2.2&3.0.
(Reporter)

Comment 1

4 years ago
Created attachment 8607439 [details]
VID_0002.mp4
(Reporter)

Updated

4 years ago
status-b2g-v2.2: --- → affected
status-b2g-master: --- → affected
This seems to be Nexus-5 specific and doesn't reproduce on the Flame. Joe, can you find an owner for this and move it to the right component?
Flags: needinfo?(joechengla)
Hi Gerry, please help to check this.

Adding [flame-l-testing-needed] for later verification.
Component: Gaia::First Time Experience → Gaia::System::Wifi
Flags: needinfo?(gchang)
Whiteboard: [2.2-nexus-5-l] → [2.2-nexus-5-l][flame-l-testing-needed]
I found that this issue also happened at flame-kk 3.0. Not sure if this is device specific.

Build ID               20150522160200
Gaia Revision          f4486f7c7785b66e8dbfc775677d1b6386718e96
Gaia Date              2015-05-22 12:19:52
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/a69094e0f2a4
Gecko Version          41.0a1
Flags: needinfo?(gchang)
Removing ni flag, we should re-test to see if this is still a problem though, so adding qa-wanted. Can we check flame-kk, and aries if possible?
Flags: needinfo?(joechengla)
Keywords: qawanted
I was able to reproduce this issue on today's Flame and Aries. It doesn't show connecting when connecting to the hotspot at step 7.

When this issue happens on the actual FTU (STR and video both show within the fake FTU in settings), I see the device appears to still try to connect to the previous wifi hotspot after I did step 7. So basically after step 7 it seems to connect to the new hotspot AND trying endlessly to connect to previous hotspot. I have seen this odd behavior happening since a long time ago so maybe all these issues are related.

Device: Flame 2.5
BuildID: 20150911030227
Gaia: 6280500a6cb8d1b178cdd163450e36d22846fbed
Gecko: c0abc2a6e11f52761366e029eb1bae4c9864a8a3
Gonk: c4779d6da0f85894b1f78f0351b43f2949e8decd
Version: 43.0a1 (2.5) 
Firmware Version: v18Dv4
User Agent: Mozilla/5.0 (Mobile; rv:43.0) Gecko/43.0 Firefox/43.0

Device: Aries 2.5
BuildID: 20150911153617
Gaia: 758c75ee087ea3722213ea2c185cca1d952c8a29
Gecko: 19f806034f67e8fc84b352db10f1a21ab982670f
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 43.0a1 (2.5) 
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:43.0) Gecko/43.0 Firefox/43.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmercado)
Keywords: qawanted
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmercado)

Comment 7

9 months ago
Firefox OS is not being worked on
Status: NEW → RESOLVED
Last Resolved: 9 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.