[Metrics] Record Startup Time for Gaia Apps

RESOLVED DUPLICATE of bug 1177226

Status

Firefox OS
Gaia::System
RESOLVED DUPLICATE of bug 1177226
3 years ago
3 years ago

People

(Reporter: thills, Unassigned)

Tracking

(Blocks: 2 bugs)

unspecified
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(feature-b2g:2.5+)

Details

(Reporter)

Description

3 years ago
Requirement is to record the startup time for Gaia Apps under the new architecture.  This will be tracked as a Histogram.
(Reporter)

Updated

3 years ago
Blocks: 1152000
Currently, we're getting the cold and warm startup time using the 'apploadtime' event, which is the same event the developer HUD uses to record app startup time. We've introduced a new file system/js/ttl_telemetry.js to listen to this event and to send the "advanced telemetry" event to the system app's advanced telemetry component.
Depends on: 1177226
After discussion with Tamara, Eli, and Jan we've decided to record app startup time based on the 'fullyLoaded' performance marker.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1177226
Blocks: 1180699
feature-b2g: --- → 2.5+
You need to log in before you can comment on or make changes to this bug.