Tracking Protection not blocking Google Tag Manager

RESOLVED WORKSFORME

Status

()

Firefox
Tracking Protection
RESOLVED WORKSFORME
3 years ago
2 years ago

People

(Reporter: jpetto, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
While testing the GTM conversion for mozilla.org (currently on demo1[0]), we noticed that the Google Tag Manager script[1] is not blocked when Tracking Protection is enabled.

Can/should this script be added to the block list?

FWIW, the GA script[2] *is* blocked by Tracking Protection.

[0] - https://www-demo1.allizom.org/en-US/
[1] - https://www.googletagmanager.com/gtm.js
[2] - https://www.google-analytics.com/analytics.js

Comment 1

3 years ago
(In reply to Jon Petto [:jpetto] from comment #0)
> While testing the GTM conversion for mozilla.org (currently on demo1[0]), we
> noticed that the Google Tag Manager script[1] is not blocked when Tracking
> Protection is enabled.
> 
> Can/should this script be added to the block list?
> 
> FWIW, the GA script[2] *is* blocked by Tracking Protection.
> 
> [0] - https://www-demo1.allizom.org/en-US/
> [1] - https://www.googletagmanager.com/gtm.js
> [2] - https://www.google-analytics.com/analytics.js

So the question is why GA blocked with tracking protection and why GTM is not?
(Reporter)

Comment 2

3 years ago
(In reply to Chris More [:cmore] from comment #1)
> So the question is why GA blocked with tracking protection and why GTM is
> not?

Yep.
Component: DOM: Security → Safe Browsing
Product: Core → Toolkit
(In reply to Jon Petto [:jpetto] from comment #2)
> (In reply to Chris More [:cmore] from comment #1)
> > So the question is why GA blocked with tracking protection and why GTM is
> > not?
> 
> Yep.

And the answer is that it's not in the upstream list we get from Disconnect:

  https://github.com/mozilla-services/shavar-prod-lists/blob/master/disconnect-blacklist.json

Marking as WORKSFORME because the feature is working as intended even though the list is missing some trackers.

Of course, it would be great to get this fixed. You can submit this missing entry to Disconnect using their feedback form:

  https://disconnect.me/trackerprotection#feedback
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
Component: Safe Browsing → Tracking Protection
Product: Toolkit → Firefox
(Reporter)

Comment 4

2 years ago
Submitted the GTM script to Disconnect.
You need to log in before you can comment on or make changes to this bug.