Closed Bug 1166330 Opened 6 years ago Closed 6 years ago

test_sms_with_picture_attached.py: "TimeoutException: TimeoutException: Timed out after 20.3 seconds"

Categories

(Firefox OS Graveyard :: Gaia::UI Tests, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(b2g-v2.2 fixed, b2g-master fixed)

RESOLVED FIXED
Tracking Status
b2g-v2.2 --- fixed
b2g-master --- fixed

People

(Reporter: onelson, Assigned: martijn.martijn)

References

Details

Attachments

(3 files)

Description:


* http://jenkins1.qa.scl3.mozilla.com/view/UI/job/flame-kk-319.mozilla-central.nightly.ui.functional.smoke/241/HTML_Report/
* http://jenkins1.qa.scl3.mozilla.com/view/UI/job/flame-kk.ui.adhoc/837/HTML_Report/

Repro Steps:
1) Update phone to 20150519010201
2) Enter Messages app
3) Create new message
4) Type number to send to (can use self)
5) Type a message body
6) Tap paperclip to add attachment -> from Gallery
7) Tap picture to send; crop picture
8) Confirm adding picture to message
9) Tap picture to view photo before sending

Actual:
Test lingers on view image screen, fails on timeout without navigating away

Expected: 
Test returns from crop screen and sends message via SMS/MMS service


Traceback (most recent call last):
File "/var/jenkins/2/workspace/flame-kk.ui.adhoc/.env/local/lib/python2.7/site-packages/marionette_client-0.13-py2.7.egg/marionette/marionette_test.py", line 296, in run
testMethod()
File "/var/jenkins/2/workspace/flame-kk.ui.adhoc/tests/python/gaia-ui-tests/gaiatest/tests/functional/messages/test_sms_with_picture_attached.py", line 61, in test_sms_cropped_picture
view_image = attachment_options.tap_view_button()
File "/var/jenkins/2/workspace/flame-kk.ui.adhoc/tests/python/gaia-ui-tests/gaiatest/apps/messages/regions/attachment_options.py", line 29, in tap_view_button
return ViewImage(self.marionette)
File "/var/jenkins/2/workspace/flame-kk.ui.adhoc/tests/python/gaia-ui-tests/gaiatest/apps/gallery/regions/view_image.py", line 24, in __init__
*self._image_locator))))
File "/var/jenkins/2/workspace/flame-kk.ui.adhoc/.env/local/lib/python2.7/site-packages/marionette_driver-0.7-py2.7.egg/marionette_driver/wait.py", line 143, in until
cause=last_exc)
TimeoutException: TimeoutException: Timed out after 20.3 seconds


Environmental Variables:
Device firmware (base) 	L1TC100118D0
Device firmware (date) 	19 May 2015 08:30:11
Device firmware (incremental) 	eng.cltbld.20150519.043000
Device firmware (release) 	4.4.2
Device identifier 	flame
Device memory 	219772 kB
Device serial 	e474dac5
Device uptime 	0 days 0 hours 2 minutes 14 seconds
Gaia date 	18 May 2015 18:07:25
Gaia revision 	762cbd167124
Gecko build 	20150519010201
Gecko revision 	f65cc0022a0e
Gecko version 	41.0a1

Reproducible manually: NO

Repro frequency: 5/5
Assignee: nobody → martijn.martijn
Comment on attachment 8607597 [details] [review]
[gaia] mwargers:1166330 > mozilla-b2g:master

This makes the test at least run for me until the sms is actually sent. The sending itself is failing here locally for me, but I think that has something to do with my provider.
Attachment #8607597 - Flags: review?(npark)
Comment on attachment 8607597 [details] [review]
[gaia] mwargers:1166330 > mozilla-b2g:master

Njpark is on pto, so asking review to others.
Attachment #8607597 - Flags: review?(npark)
Attachment #8607597 - Flags: review?(jlorenzo)
Attachment #8607597 - Flags: review?(gmealer)
The bitbar adhoc run passed: http://jenkins1.qa.scl3.mozilla.com/job/flame-kk.ui.adhoc.bitbar/48/testReport/%28root%29/
However, I added a repeat of 5 to it, but it only ran 1 time. Dave, do you know why that happens?
Flags: needinfo?(dave.hunt)
It looks like the repeat parameter was not being consumed by the managed script. I've hopefully fixed this now, and triggered http://jenkins1.qa.scl3.mozilla.com:8080/view/Bitbar/job/flame-kk.ui.adhoc.bitbar/49/
Flags: needinfo?(dave.hunt)
(In reply to Dave Hunt (:davehunt) from comment #6)
> It looks like the repeat parameter was not being consumed by the managed
> script. I've hopefully fixed this now, and triggered
> http://jenkins1.qa.scl3.mozilla.com:8080/view/Bitbar/job/flame-kk.ui.adhoc.
> bitbar/49/

Looks like the job failed with an error.
Flags: needinfo?(dave.hunt)
Comment on attachment 8607597 [details] [review]
[gaia] mwargers:1166330 > mozilla-b2g:master

This change doesn't look prone to intermittents, so r+'ing it even without the repeat-5 job.

Looks fine, but is the need to not tap cancel anymore reflect an expected change? The linked moztrap case doesn't really define that part.

NI'ing Oliver for that question. Since it's a smoketest it should be on his radar.
Flags: needinfo?(onelson)
Attachment #8607597 - Flags: review?(gmealer) → review+
(In reply to Geo Mealer [:geo] from comment #7)
> (In reply to Dave Hunt (:davehunt) from comment #6)
> > It looks like the repeat parameter was not being consumed by the managed
> > script. I've hopefully fixed this now, and triggered
> > http://jenkins1.qa.scl3.mozilla.com:8080/view/Bitbar/job/flame-kk.ui.adhoc.
> > bitbar/49/
> 
> Looks like the job failed with an error.

It failed to clone the repository, a rebuild seems to be okay: http://jenkins1.qa.scl3.mozilla.com:8080/view/Bitbar/job/flame-kk.ui.adhoc.bitbar/50
Flags: needinfo?(dave.hunt)
Looked at the test and reflected with the expected flow for the manual smoketest:

That line you scrapped "attachment_options.tap_cancel()" wasn't in the manual UI flow anymore, jumping back from the 'image-view' of an attached image doesn't navigate the driver back to the activities list, we were waiting indefinitely for a UI that didn't appear.

Looks good, good find. I can keep an eye open for obsolete UI flows in future test errors.
Flags: needinfo?(onelson)
Comment on attachment 8607597 [details] [review]
[gaia] mwargers:1166330 > mozilla-b2g:master

(In reply to Geo Mealer [:geo] from comment #8)
As it was a 5/5 failure and based on comment 10, the fix seems also correct to me.
Attachment #8607597 - Flags: review?(jlorenzo) → review+
https://github.com/mozilla-b2g/gaia/commit/b290c77ccb7ab0af599b3d8287b71b9970d8dcb0
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Blocks: 1166632
Hi Martijn,
Sorry, I just uplifted the patch again. Could you review it again? Please merge it to v2.2 if it's possible. Thanks a lot.
Attachment #8613897 - Flags: review?(martijn.martijn)
Comment on attachment 8613897 [details] [review]
[gaia] cynthiatang:v2.2 > mozilla-b2g:v2.2

I'm assuming this works on v2.2 for you.
Attachment #8613897 - Flags: review?(martijn.martijn) → review+
Duplicate of this bug: 1166632
You need to log in before you can comment on or make changes to this bug.