Navigation browsing action points of reloading,forwarding and backwarding to a page are not working at all under XP

RESOLVED WORKSFORME

Status

()

Core
Document Navigation
--
major
RESOLVED WORKSFORME
16 years ago
10 years ago

People

(Reporter: Vladimir Krasojevic, Assigned: Radha on family leave (not reading bugmail))

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:0.9.6) Gecko/20011120
BuildID:    2001112009

Ever since I downloaded the latest version of Mozilla 0.9.6 I was never able to
go forwards or backwards. The icons on the top left corner of the browser are
never active nor allowing the chance to be used at all. However this version
works perfectly fine under Windows 98. I think this version I am running has
incompatibility problems with XP or something else is missing. Is there some
extra patches that need installing for this to work properly or what shall I do
to fix this problem? Please help.

Reproducible: Always
Steps to Reproduce:
1.Turn on the computer
2.Double click on Mozilla to activate
3.Start browsing

Actual Results:  I can only browse by typing the actual URL address in the
location bar. Going back to the previous page is doable but not practical in the
sense that I cannot make any use of the navigation links provided by the actual
browser.

Expected Results:  I should be able to browse normally. If I wanted to go back
to the previous page I visited I should be able to achieve that simply by
clicking on to the navigation point arrow to return.  

Sometimes Mozilla would freeze forcing me to close all applications that are
running at that time. Also webpages with flash animations I can not load as I'm
missing a java plug-in. This shouldn't happen but it does every time I visit any
site with flash animation on. After installation of the proper java plug-in the
problem would still persist.
Reporter:
Only 1 problem/bug :-)

1. Please install 0.9.7 (0.9.6 is old) :-)
Be sure that you install it in a fresh directory (not over an older build)
If that doesn't work, create a new profile (with mozilla -profilemanager)

2. There is a known Java installer bug.
from the release notes (0.9.7):
---------------------------------------------------------------------
If Java doesn't work, make sure the following is true:
On Windows:
Copy the NPOJI610.DLL from C:\JDK*\jre\bin to "\plugins" directory of your
installation.
----------------------------------------------------------------------

It's npoji600.dll if you have installed JRE1.3x
Component: Keyboard Navigation → History: Session
->default session history owners, but punt if this belongs elsewhere!
Assignee: aaronl → radha
QA Contact: sairuh → claudius
My best guess based on the description of the problem is, session history is
probably disabled in Prefs. go to Edit->preferences. Expand the 'Navigator' tab.
Click on history.  The last block of the history page with title, 'Session
History' should  be like, "Number of pages in Session history: 50". Back forward
buttons won't work if this number os 0 or negative. Please check this. 

Comment 4

16 years ago
I'm using WinXP Gold, moz build: 2002 01 29 06

I can use my Back and Forward buttons just fine, so I'm resolving this one as
Resolved: Works For Me. 

Reporter: The build you were using is probably too old for this bug to be
helpful unless you can reproduce it on a recent build. If you can use a more
recent build and reproduce the problem again, please feel free to reopen this bug.

James
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME

Updated

10 years ago
Component: History: Session → Document Navigation
QA Contact: claudius → docshell
You need to log in before you can comment on or make changes to this bug.