IFRAME inside table flickers when typing in form

RESOLVED DUPLICATE of bug 104053

Status

()

Core
Layout
RESOLVED DUPLICATE of bug 104053
17 years ago
17 years ago

People

(Reporter: db, Assigned: Marc Attinasi)

Tracking

({testcase})

Trunk
mozilla1.1alpha
x86
All
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

17 years ago
Scroll down to "Article Search" and search for something and you will get to the
search page, here is a link to that page:

http://www6.tomshardware.com/cgi-bin/htsearch?words=&format=builtin-long&method=and&sort=score&config=content&restrict=&exclude=

And when you type in the "Refile Search" field the banner on top moves to the
left for each letter you type (and back again very fast). The same problem with
images moving around is in more places at tom's hardware, for example the start
page of the site. But here is a smaller page where you can trigger it by typing
which makes it into something reproducable and debuggable.

Even on the start page of the site when you enter into the searchfield the
banners move around. Also when loading the page and it reflows the content the
x,y coordinats on the banners are way of for some milliseconds making it look
really ugly. It looks just like when you type so I'm pretty sure it's the same bug.

I was using 0.9.6, but this bug have been there a long, long time (more then 6
months at least). I have not tried 0.9.7 yet, so someone might want to reproduce
it on that one.

Comment 1

17 years ago
With build 2001122208 the images flicker rather than move.
Reading your description, this sounds like a duplicate of bug 96819

If the examples in that bug description match the behaviour here, then please
mark this as a duplicate or comment here.
(Reporter)

Comment 2

17 years ago
You are right that flicker is a better word. The images moves very fast 5 cm to
the left and back again, or 10 cm up and back again.

It might be related to the other bug, but here the images does not move
permanently like in the other bug where the input field moves and stays there.

It is triggered when you type text in the form, but it is also triggered when
you load the page progressivly (maybe it's called somthing else, to show the
page before it's completly loaded).
(Reporter)

Comment 3

17 years ago
Created attachment 62731 [details]
Testcase with iframe in table that flickers

I've reduced the tom's hardware page to a testcase. The problem seems to be
tables	with iframes inside. And the aligns are important.
(Reporter)

Updated

17 years ago
Keywords: testcase

Comment 4

17 years ago
Reporter, this report is appreciated. But please use a validator for html
testcases because, sometimes, bugs are resulted from badly written html code.
The official W3C online validator can be found at http://validator.w3.org/

Confirming and attaching a corrected and simplified testcase. Platform->All.
Changing summary from "images move around while typing in entry field" to
"IFRAME inside table flickers when typing in form input".
Note: no flicker if the first table is not present. But if you remove image
link, flicker still exists.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Linux → All

Comment 5

17 years ago
Created attachment 63473 [details]
above testcase simplified

Updated

17 years ago
Summary: images move around while typing in entry field → IFRAME inside table flickers when typing in form

Updated

17 years ago
Target Milestone: --- → mozilla1.1

Comment 6

17 years ago

*** This bug has been marked as a duplicate of 104053 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.