Closed Bug 1166442 Opened 5 years ago Closed 5 years ago

[UX] Convert icons in the main window on Windows to HiDPI

Categories

(Firefox :: Theme, defect)

Unspecified
Windows
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1023511

People

(Reporter: phlsa, Unassigned)

Details

(Keywords: meta, Whiteboard: [windows10])

Priority: -- → P2
Summary: [UX] Convert icons on Windows to HiDPI → [UX] Convert icons in the main window on Windows to HiDPI
P1, even within UX context, because Firefox appears to be the only browser that isn't fully HiDPI.
Priority: P2 → P1
Which icons? The toolbar/menupanel icons on nightly and aurora should already be hidpi.
Flags: needinfo?(philipp)
(I'm asking because I'm wondering/worried that there's a bug affecting those icons only on Windows 10, or something)
To name a few:
- Hello
- Tab close buttons
- Identity block icons
- Tab separators
- Search icon
- Reload icon

We will likely use the same icon style as on Windows 8, so we'll get that platform for »free«. The focus on Windows 10 is because we see an opportunity there. The current way in which we're set up (PNGs for everything) means that we have to do a lot of work for every Windows version and Win10/8 seems to be the highest value target.
Flags: needinfo?(philipp)
(In reply to :Gijs Kruitbosch from comment #2)
> Which icons? The toolbar/menupanel icons on nightly and aurora should
> already be hidpi.

Only the toolbar icons got support for HiDPI, not the menuPanel icons. See bug 1153309.
This is a bit of a metabug, sounds like everything except the identity icons are currently filed.

Leaving as a P1 to update main/primary assets, but would be useful to note all the dependancies so we can tweak priorities as needed.
Keywords: meta
Depends on: 1168528
No longer depends on: 1173729
Priority: P1 → --
Doesn't seem any different from bug 1023511
Status: NEW → RESOLVED
Closed: 5 years ago
No longer depends on: 1168528, 1181514
Resolution: --- → DUPLICATE
Duplicate of bug: 1023511
No longer blocks: windows-10
You need to log in before you can comment on or make changes to this bug.