[Homescreen] After performing in memory-intensive apps, returning to homescreen loads empty and staggers load in

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
4 years ago
3 years ago

People

(Reporter: onelson, Unassigned)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(b2g-v2.2 unaffected, b2g-master affected)

Details

(Whiteboard: [3.0-Daily-Testing], [systemsfe], URL)

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 8607726 [details]
logcat_20150519.txt

Description:
When a user is within the browser app and performs a lot of memory intensive actions, returning to homescreen on tapping the home button will return to an empty homescreen that reveals the wallpaper. After a couple seconds, the search bar will stagger in, followed by the group-block UI, and homescreen icons.

Repro Steps:
1) Update a Flame to 20150519010201
2) Connect to Wi-Fi in Settings
3) Open the Browser app
4) Search for "www.kotaku.com"
5) Stay on webpage about 5 seconds (let content load, continue loading)
6) Tap home button
7) Observe UI (if homescreen encounters Expected Results, repeat step 5 with additional websites)

Actual:
Homescreen loads in empty; search bar staggers in, followed by group-block UI and homescreen icons

Expected:
Homescreen shows all UI with no load delays


Environmental Variables:
-----------------------------

Device: Flame 3.0
Build ID: 20150519010201
Gaia: 762cbd16712484f93f485e89f5363686540a3db7
Gecko: f65cc0022a0e
Gonk: 040bb1e9ac8a5b6dd756fdd696aa37a8868b5c67
Version: 41.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:41.0) Gecko/41.0 Firefox/41.0
**************************************

Issue DOES NOT REPRO on 2.2 for flame devices
Results: Homescreen may blink a second when returning from high memory browser activity
Device: Flame 2.2
BuildID: 20150519002500
Gaia: 732acec6f37d13ccea6b0ddc48904a53a2970894
Gecko: 1389e6b8c065
Gonk: bd9cb3af2a0354577a6903917bc826489050b40d
Version: 37.0 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
-----------------------------

Repro frequency: 4/6

See attached: 
video- https://youtu.be/dZPUnuFscwc
logcat
(Reporter)

Updated

4 years ago
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
Keywords: regression
Whiteboard: [3.0-Daily-Testing] → [3.0-Daily-Testing], [systemsfe]
This seems to happen across the device under high memory usage instances. NI homescreen owner for blocking desicion on this bug since its low repro, but happens with multiple apps
Flags: needinfo?(pbylenga) → needinfo?(hcheng)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Are the memory settings between 2.2 and master the same? (319MB?)
Flags: needinfo?(hcheng)
Seth, does this sound like its caused by one of your patches?
Flags: needinfo?(seth)
(In reply to Gregor Wagner [:gwagner] from comment #3)
> Seth, does this sound like its caused by one of your patches?

At the moment, no. It'd be nice to have a more detailed regression range.
Flags: needinfo?(seth)
Mass update: Resolve wontfix all issues with legacy homescreens.

As of 2.6 we have a new homescreen and having these issues open is confusing. All issues will block bug 1231115 so we can use that to re-visit any of these if needed.
Blocks: 1231115
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.