Rename "timeline" details view

RESOLVED DUPLICATE of bug 1150761

Status

()

Firefox
Developer Tools: Performance Tools (Profiler/Timeline)
RESOLVED DUPLICATE of bug 1150761
3 years ago
3 years ago

People

(Reporter: jsantell, Unassigned)

Tracking

41 Branch
Points:
---

Firefox Tracking Flags

(firefox41 affected)

Details

The waterfall view shouldn't be called a "timeline", as the overview views are more of a timeline, ("all views are timelines"), we should call it "Markers" or "waterfall" or something
"Waterfall" or "Timeline" -- I don't think "Markers" is intuitive at all (at least for me). You have to know what a "marker" is for it to make sense.
I would suspect "waterfall" might sound weird for some people. Is it really wrong to call it "timeline"?
"history"
"breakdown"
"actions"
...
"stuff"?

I would just stick with timeline.
DevRel pointed out that it was confusing as they thought of the "overview graphs" as the timeline, which makes sense: its where you select and scrub through time ranges and its related to each of the detail views. 

"Markers" isn't indicative of how you see data, just the name of the data source, and we don't make clear that markers !== samples. 

"Waterfall" I think is the best name for this as it describes the view as an easy way out, unless there's a less jargon-laden word for "events" (to not be confused with DOM events)
(Reporter)

Updated

3 years ago
Blocks: 1075567
Moving to bug 1150761
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1150761
You need to log in before you can comment on or make changes to this bug.