Right-clicks interpreted as left-clicks

VERIFIED INVALID

Status

()

Core
Event Handling
P3
normal
VERIFIED INVALID
19 years ago
a year ago

People

(Reporter: cpratt, Assigned: David Hyatt)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
Build ID: 1999081008
Platform: Windows NT (investigating Linux, Mac OS)

To reproduce:
- Launch apprunner
- Right-click on the Mozilla.org button (for example)

Result: Mozilla.org is loaded.

Expected result: Nothing should happen (there are no contextual menus for
toolbar buttons).

Updated

19 years ago
Assignee: joki → hyatt

Comment 1

19 years ago
left and right clicks are only differentiated via the 'button' property on the
event object.  We'll need to start checking this before activating UI.  Sending
to hyatt at its either his or he's knows who to give it to.
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
Target Milestone: M15
(Assignee)

Comment 2

19 years ago
Actually, there will be contextual menus for toolbar buttons.

This shouldn't be much of an issue for the content area, since the content area
will have a right-click capturer that will consume the click.  As for clicks in
the chrome, well, there will probably have to be some checks added on the part
of UI designers.

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → INVALID

Comment 3

19 years ago
resolving as invalid per hyatt
(Reporter)

Updated

19 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Comment 4

19 years ago
OK.
You need to log in before you can comment on or make changes to this bug.