[Music][Share Activity] Loading a music share activity after a fresh flash displays an empty memory card message without a loading animation before the songs become available.

RESOLVED DUPLICATE of bug 963622

Status

RESOLVED DUPLICATE of bug 963622
4 years ago
4 years ago

People

(Reporter: Marty, Unassigned)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(tracking-b2g:backlog, b2g-v2.2 unaffected, b2g-master affected)

Details

(Whiteboard: [3.0-Daily-Testing], URL)

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 8607819 [details]
logcat-music-share-load.txt

Description:
If the user has music files already on the device, the first time they open a Music share activity (attaching a music file to a message or email, creating a custom ringtone), the device will erroneously display "Add songs to get started. Load songs on to the memory card."  Often times this message is displayed for more than 5 seconds before the music tracks become available.

Notes:
-This only occurs the first time a share activity is loaded if the Music app itself has not been opened first.
-In the 2.2 branch, this same screen is displayed, but a loading animation is also displayed at the top of the screen while the music app identifies local music files.

Prerequisites: User has Music files stored on the device

Repro Steps:
1) Update a Flame to 20150519010201
2) Open the messages app and compose a new message
3) Select the Attach (paperclip) button and choose Music.

Actual:
"Load songs on to the memory card." is displayed for several seconds without a loading animation before the songs are available.

Expected:
The user is given a proper loading screen with animation before the songs are available for selection.

Environmental Variables:
Device: Flame 3.0 (Full Flash)
Build ID: 20150519010201
Gaia: 762cbd16712484f93f485e89f5363686540a3db7
Gecko: f65cc0022a0e
Gonk: 040bb1e9ac8a5b6dd756fdd696aa37a8868b5c67
Version: 41.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:41.0) Gecko/41.0 Firefox/41.0

Repro frequency: 10/10
See attached: Video (URL), Logcat
(Reporter)

Comment 1

4 years ago
This issue does NOT occur on Flame 2.2 builds.
The user is given the same empty memory card message, but is also presented with loading animations at the top of the screen indicating that the songs are being loaded.

Environmental Variables:
Device: Flame 2.2 (Full Flash)
Build ID: 20150519002500
Gaia: 732acec6f37d13ccea6b0ddc48904a53a2970894
Gecko: 1389e6b8c065
Gonk: bd9cb3af2a0354577a6903917bc826489050b40d
Version: 37.0 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
Confusing UX. Regression. Requesting a window
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
Keywords: regressionwindow-wanted
[Blocking Requested - why for this release]:
blocking-b2g: --- → 3.0?
QA Contact: pcheng
b2g-inbound regression window:

Last Working
Device: Flame
BuildID: 20150408112334
Gaia: 2a782fffe23bea0b6ed37ed0cf45de755ace2ec3
Gecko: d14ec217cd64
Version: 40.0a1 (3.0 Master) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0

First Broken
Device: Flame
BuildID: 20150408115335
Gaia: 5dfd0460eb6e616205154b0d219aa5123bf1abb3
Gecko: 2974fc1a396a
Version: 40.0a1 (3.0 Master) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0

Last Working Gaia & First Broken Gecko - no repro
Gaia: 2a782fffe23bea0b6ed37ed0cf45de755ace2ec3
Gecko: 2974fc1a396a

Last Working Gecko & First Broken Gaia - repro
Gaia: 5dfd0460eb6e616205154b0d219aa5123bf1abb3
Gecko: d14ec217cd64

Gaia pushlog:
https://github.com/mozilla-b2g/gaia/compare/2a782fffe23bea0b6ed37ed0cf45de755ace2ec3...5dfd0460eb6e616205154b0d219aa5123bf1abb3

Caused by Bug 1147032.
Blocks: 1147032
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: regressionwindow-wanted
Jim, can you take a look at this please? This might have been caused by the landing for bug 1147032.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker) → needinfo?(squibblyflabbetydoo)
I don't see a delay of "several seconds". It takes about a second, tops, before the music app starts showing actual music, at which point, it should be fairly clear what's happening. This is far and away better than it was in 2.2, where you were completely unable to back out of the activity once it started showing music; you had to wait until it was finished scanning.

While we could change the alert's text or something to make it clearer what's happening, I think this is a pretty low priority, given that it's only onscreen for a moment, and that the old UX was quite a bit worse.
Flags: needinfo?(squibblyflabbetydoo)
blocking-b2g: 3.0? → 3.0+
[Tracking Requested - why for this release]:
Making backlog instead based on comment 6.
blocking-b2g: 3.0+ → ---
tracking-b2g: --- → backlog
I think this is actually a dupe of bug 963622, although in a slightly-different form.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 963622
You need to log in before you can comment on or make changes to this bug.