Remove some PL_DHashTable{Init,Finish}() calls

RESOLVED FIXED in Firefox 41

Status

()

defect
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: njn, Assigned: njn)

Tracking

unspecified
mozilla41
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox41 fixed)

Details

Attachments

(2 attachments)

All going towards re-combining PLDHashTable and PLDHashTable2.
This is very similar to bug 1161377 part 2, except that (a) a few variables
changes to PLDHashTable2, and (b) I haven't removed the definitions of
PL_NewDHashTable/PL_DHashTableDestroy yet because I want to save all the
changes affecting comm-central for later.
Attachment #8607901 - Flags: review?(nfroyd)
This is much like bug 1161377 part 3, but with some PLDHashTable2 occurrences
as well.
Attachment #8607902 - Flags: review?(nfroyd)
> (part 2) - Convert some easy PL_DHashTable{Init,Finish} cases

Well, this is interesting. I've done some tests with autophone and it's clearly showing that the changes to gfxFT2FontList.cpp are causing a Fennec startup speed regression. I don't understand why. If I can't work out why tomorrow, I'll probably just undo that part of the patch and land the rest, and then worry about those changes later.
Attachment #8607901 - Flags: review?(nfroyd) → review+
Attachment #8607902 - Flags: review?(nfroyd) → review+
I did another, slightly different set of autophone pushes this morning that confirmed that the gfxFT2FontList.cpp change hurt Android startup time. So I didn't land them.
https://hg.mozilla.org/mozilla-central/rev/f348858d944e
https://hg.mozilla.org/mozilla-central/rev/b46f7d0b2c4b
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla41
(In reply to Nicholas Nethercote [:njn] from comment #1)
> This is very similar to bug 1161377 part 2, except that (a) a few variables
> changes to PLDHashTable2, and (b) I haven't removed the definitions of
> PL_NewDHashTable/PL_DHashTableDestroy yet because I want to save all the
> changes affecting comm-central for later.
Thank you for keeping comm-central in mind. If I understand the comments correctly PL_NewDHashTable becomes new PLDHashTable2 vis a vis https://hg.mozilla.org/comm-central/rev/95616afdd719
> Thank you for keeping comm-central in mind. If I understand the comments
> correctly PL_NewDHashTable becomes new PLDHashTable2 vis a vis
> https://hg.mozilla.org/comm-central/rev/95616afdd719

Right now, yes. But I have follow-up patches, already written, that merge PLDHashTable2 back into PLDHashTable. I will try to work things so that all the changes that will break comm-central can be addressed in a single patch.
You need to log in before you can comment on or make changes to this bug.