Spell Checker UI: Please rearrange "Ignore" and "Change" buttons

VERIFIED FIXED in mozilla0.9.8

Status

SeaMonkey
Composer
--
enhancement
VERIFIED FIXED
16 years ago
13 years ago

People

(Reporter: Peter Lairo, Assigned: Charles Manske)

Tracking

Trunk
mozilla0.9.8

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

1.25 KB, patch
glazou
: review+
Joe Hewitt (gone)
: superreview+
Details | Diff | Splinter Review
(Reporter)

Description

16 years ago
Spell Checker UI: Please rearrange "Ignore" and Change" buttons

RE. screenshot in bug 56301#71: ftp://ftp.cs.cornell.edu/pub/nogin/spell.png

I think it would be much better if the ignore/ignore all and change/change all
were vertically ordered instead of side-by-side. For some reason, i think that
makes it easier/quicker to identify and read.

Could you make it look like this:

+- Check Spelling ---------------------------------+
|                                                  |
| Suggestions:                                     |
| +--------------+                                 |
| |              |  [   Change   ]  [   Ignore   ] |  <-- these buttons
| |              |  [ Change All ]  [ Ignore All ] |  <-- and these
| |              |                                 |

That way, the user could mainly focus on the top two (most visible/discoverable)
buttons. Also, the buttons just look better grouped that way. :)
(Reporter)

Updated

16 years ago
Depends on: 56301
Keywords: mozilla0.9.8, ui
Summary: Spell Checker UI: Please rearrange "Ignore" and Change" buttons → Spell Checker UI: Please rearrange "Ignore" and "Change" buttons
(Reporter)

Comment 1

16 years ago
CC'ing Deinst@world.std.com (David Einstein) and rcassin@supernova.org (Ryan
Cassin), in case they are interested :)

Comment 2

16 years ago
*Looks* better. However, the mouse way between Change and Ignore (2 options,
between which users will often switch) is then longer.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 3

16 years ago
RE comment #2: Actually, for me, at least, it is much easier to move the mouse
in a horizontal line than in a vertical line ;)

Comment 4

16 years ago
-->cmanske
Assignee: kin → cmanske
Component: Editor: Core → Editor: Composer
(Assignee)

Comment 5

16 years ago
Sounds like a reasonable request to me. Trivial to implement, of course.
Any reasons for/against putting "Ignore" items in the 1st (left) column instead
of "Change" buttons ? 
Any other opinions?
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla0.9.9
(Reporter)

Comment 6

16 years ago
"Ignore" in first collumn souds like a great idea. I'm pretty sure that "Ignore"
wll be (slightly) more used than "change", and should therefore receive the
(slightly) more prominent position.

+- Check Spelling ---------------------------------+
|                                                  |
| Suggestions:                                     |
| +--------------+                                 |
| |              |  [   Ignore   ]  [   Change   ] |
| |              |  [ Ignore All ]  [ Change All ] |
| |              |                                 |

Comment 7

16 years ago
I think "change" should be the top/left button since most users are going to use
this one the most.  One can always "Add Word" to avoid use of "Ignore" but there
isn't a "workaround" to avoiding changing a misspelled word.  Also, "Ignore"
really doesn't have anything to do with the suggestions list, it has to do with
the text field above it.

Perhaps the layout should be something completely different like:
(apologies in advance, I'm not the greatest ascii artist)

+- Check Spelling ---------------------------------+
|                                                  |
|  Misspelled word:  foobar         [   Ignore   ] |
|                                   [ Ignore All ] |
|  Change to:  [footer           ]  [ Check Word ] |
|                                                  |
| Suggestions:                                     |
| +--------------+                                 |
| | footer       |  [   Change   ]  [ Change All ] |
| | Faber        |                                 |
| | fibber       |                                 |
| | fiber        |  User Dictionary:               |
| |              |                                 |
| |              |  [  Add Word  ]  [   Edit...  ] |
| |              |                                 |
| +--------------+                                 |
| Language:                                        |
| [English/US   v]  [  Recheck   ]  [    Close   ] |
|                                                  |
+--------------------------------------------------+

Comment 8

16 years ago
The 'misspelled word' and 'change to fields should have as much horizontal space
as possible. Even now, forgetting the space between two long words is problematic.

Comment 9

16 years ago
+- Check Spelling -----------------------+ 
| Text:      |foobar    | [    Skip    ] | <- It's Text, We're telling the user that it isn't a word. <- The user doesn't care for the moment, skip it.
|                         [   Ignore   ] | <- The user likes what's there. Ignore it.
| Change to: [footer    ] [   Lookup   ] | <- The user typed something and wants to know if it's a word in the dictionary. 'Check Word' is silly, something like "I know this is a word, why don't you believe me?"
|                         [  Replace   ] | <- Replace the current text
| Suggestions:            [ Change All ] | <- I'm open to discussion
| +---------------------+                | <- 'Custom' can be stuck here if people insist.
| | footer              | Dictionary:    |
| | Faber               | [  Add Word  ] |
| | fibber              | [  Edit...   ] |
| | fiber               | [English/US|v] | <- We could write 'Language:' and waste an extra line, but i don't see any value in it.
| |                     |                |
| |                     | [  Recheck   ] |
| +---------------------+ [   Done     ] | <- mpt? Stop/Done is one way to go.  If the spell checker is 'finished checking' show Done, otherwise show Stop. Either way the user always know where to click to close the dialog.
+----------------------------------------+

For reference, nc4unix[fbsd]

+- Check Spelling -----------------------+ 
| Word:                                  |
| [                     ] [Replace/Done] | <- One or the other, 
| Suggestions:            [Replace All ] | <- The Suggestions box is twice as tall as shown in this art,
| +---------------------+ [   Check    ] | <- The buttons to the right are spaced out more (about 1/2 line)
| |                     | [   Ignore   ] |
| |                     | [ Ignore All ] |
| |                     | [   Learn    ] |
| +---------------------+ [   Stop     ] |
| [English/US         |v]                |
| ["[finish checking]"                 ] | <- status message
+----------------------------------------+

There's something to be said for putting labels above the editbox.

Alternative 1. [All Words negotiable]
+- Check Spelling: Foobar----------------+ <- Text being examined in title.
| [  Skip  ] [  Ignore  ] [   Learn    ] |
| [>footer             <] [  Replace   ] | <- Editable text for replacement.
| [ Lookup ]              [ Change All ] |
| Suggestions:                           |
| +---------------------+ Dictionary:    |
| | footer              | [English/US|v] |
| | fiber               | [  Edit...   ] |
| | fibber              |                |
| |                     | [  Recheck   ] |
| +---------------------+ [   Done     ] |
+----------------------------------------+
(Assignee)

Comment 10

16 years ago
Interesting suggestions. Note that the "default" key (what will execute when
Enter/Return is pressed) is the 'Change' button if there is a suggested
replacement word, or 'Ignore' if there is no suggested replacement. Just thought
that info is useful to know when considering changes to the button locations. 
Even though I agree that "Ignore" doesn't have anything to do with replacement
list, I feel that the proximity of the 2 (or really 4) most-used buttons, Change
and Ignore, is important. I like the original suggestion of how to rearrange
how those 4 buttons group. If "Change" is more likely to be used, as Kathy 
suggests, and also given her point about relevance of the "Ignore" to the 
suggested list, I vote for using the original suggested layout change with 
"Change" buttons on the left. I also agree that we need to maximize the width of
the editfield for the replacement word.
(Reporter)

Comment 11

16 years ago
Whatever you guys end up deciding, please make it the highest priority that the
user can *quickly* and *easily* find the buttons he will be looking for! I
honestly think that "technically correct" UI is a *distant* second to usability. :)

I kind of still like my original suggestion best because the "Replace" and
"Ignore" buttons (most frequently used, IMO) are closest together, plus there
are no visual obstacles or "diagonal" mouse navigation between them.

PS. I don't care that much if "change" is on the left or right (until I've seen
and used it).
(Assignee)

Comment 12

16 years ago
Created attachment 63419 [details] [diff] [review]
Fix.

I'm not sure if this is just a coincidence, but that annoying missing pixel in
the buttons in this dialog are now gone!
(Assignee)

Updated

16 years ago
Whiteboard: FIX IN HAND, need r=,sr=
Target Milestone: mozilla0.9.9 → mozilla0.9.8
Comment on attachment 63419 [details] [diff] [review]
Fix.

r=glazman
Attachment #63419 - Flags: review+
(Assignee)

Updated

16 years ago
Whiteboard: FIX IN HAND, need r=,sr= → FIX IN HAND, need sr=
(Reporter)

Comment 14

16 years ago
Now how about getting the Spellchecker into the trunk? ;)

Comment 15

16 years ago
Comment on attachment 63419 [details] [diff] [review]
Fix.

sr=hewitt
Attachment #63419 - Flags: superreview+

Comment 16

16 years ago
And now what? We have the UI but not the spellchecker?
(Reporter)

Comment 17

16 years ago
Andrea: Sure we have a spell checker. Here it is in bug 56301:
http://bugzilla.mozilla.org/attachment.cgi?id=62548&action=view
(Assignee)

Comment 18

16 years ago
checked in 
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
Whiteboard: FIX IN HAND, need sr=

Comment 19

16 years ago
Peter: I know we have bug 56301, I was amused from the fact that now we have
spell-checker UI checked in but not the spell-checker itself checked in! I
think, if the spell-checker is somehow usable, it should be checked in (and, if
needed, switched off by default in 0.9.8).

Comment 20

16 years ago
we have a spellchecker ui because netscape donated it to the mozilla.org 
project and for those of us who use n6 we have a licensed spellchecker 
implementation too

Updated

16 years ago
No longer depends on: 56301

Comment 21

16 years ago
PEter, is this fixed for you now? please verify...
(Assignee)

Comment 22

16 years ago
The buttons are arranged exactly as Peter originally suggested.
verified.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.