Button in attachment file selection dialog incorrectly labelled "Open"

RESOLVED DUPLICATE of bug 23470

Status

RESOLVED DUPLICATE of bug 23470
4 years ago
4 years ago

People

(Reporter: u528881, Unassigned)

Tracking

31 Branch

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/42.0.2311.152 Safari/537.36

Steps to reproduce:

Start composing a new message. Go to "File" menu, "Attach" submenu and select "File(s)".


Actual results:

The dialog that comes up has buttons "Cancel" and "Open" at the bottom.


Expected results:

"Open" is misleading. The file won't be opened, such as for viewing or editing. Button should say something else, probably "Attach".

It is labelled "Open" both in Windows 7 and Linux.

I don't care about cosmetic issues like this; I just want software to work. However, my mom has repeatedly bugged me about this while learning Thunderbird so I am reporting it.
Boris, thanks for reporting and your mom is right :) However, this cosmetic fix is actually non-trivial because the dialogues are native OS dialogues so it's not easy to tweak them.

This problem has already been reported as bug 23470.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 23470
You need to log in before you can comment on or make changes to this bug.