[Keyboard] 'Joining Hidden Network' page may reveal homescreen on keyboard transitioning between 'SSID Network Name' and 'Password' fields

VERIFIED FIXED

Status

Firefox OS
Gaia::Keyboard
VERIFIED FIXED
3 years ago
2 years ago

People

(Reporter: oliverthor, Unassigned)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(blocking-b2g:2.5?, b2g-v2.2 unaffected, b2g-v2.5 verified, b2g-master verified)

Details

(Whiteboard: [3.0-Daily-Testing], URL)

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8608314 [details]
logcat_20150520_1142.txt

Description:
If the user navigates to the UI page for 'Joining Hidden Network' [Settings app --> Manage Networks --> Join Hidden Network], they may observe when switching between the text fields 'SSID Network Name' and 'Password', that the spelling-suggestions UI that shows for Name will disappear when moving to Password. When this action occurs, the homescreen is revealed momentarily before flashing the UI back onto screen.
This was halo tested around similar keyboard fields where a keyboard with spelling suggestions UI is displayed, and transitioning to a different text field which des not support it, such as:
* Email Manual Setup: SSL --> Hostname, Password
* Add New Contact: First Name, Last Name --> Phone Number
It also appears that after performing the above actions, the issue within 'Joining Hidden Network' will fix itself and no longer reveal homescreen.


Repro Steps:
1) Update a Flame to 20150520010202
2) Open Settings app
3) Navigate through 'Manage Networks'
4) Navigate through 'Join Hidden Networks'
5) Tap into text field for 'SSID Network Name'; observe keyboard + spelling suggestions
6) Tap into 'Password'; observe keyboard + spelling suggestions

Actual:
Keyboard Spelling Suggestions disappears transitioning into password and reveals homescreen

Expected:
Keyboard Spelling Suggestions disappears without revealing homescreen


Environmental Variables:
------------------------------ 

Device: Flame 3.0
Build ID: 20150520010202
Gaia: 600fd8249960b8256af9de67d9171025bb9a3ff3
Gecko: ac277e615f8f
Gonk: 040bb1e9ac8a5b6dd756fdd696aa37a8868b5c67
Version: 41.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:41.0) Gecko/41.0 Firefox/41.0
*************************

Issue DOES NOT REPRO on 2.2 for flame devices:
Results: Keyboard Spelling Suggestions disappears without revealing homescreen

Device: Flame 2.2
BuildID: 20150520002502
Gaia: 63e9eeec3032318f8a240f80b6a184fa4b50b6e1
Gecko: a89755309dea
Gonk: bd9cb3af2a0354577a6903917bc826489050b40d
Version: 37.0 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
-----------------------------------

Repro frequency: 5/6
See attached: 
video- https://youtu.be/pTS6jR02lFI
logcat
(Reporter)

Updated

3 years ago
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
[Blocking Requested - why for this release]:

Visible regression in multiple areas of the phone. Requesting a window. Nominating to block
blocking-b2g: --- → 3.0?
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
Keywords: regressionwindow-wanted
QA Contact: jmercado
I won't be able to finish this window by the end of the day.  Here is the central window for this issue.  Please note that this issue requires Software home button to be active in order to reproduce and seems to reproduce much more frequently when entering settings from notification menu.

Central Regression Window:

Last Working 
Environmental Variables:
Device: Flame 3.0
BuildID: 20150518172622
Gaia: 762cbd16712484f93f485e89f5363686540a3db7
Gecko: f65cc0022a0e
Gonk: Could not pull gonk.  Did you shallow Flash?
Version: 41.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:41.0) Gecko/41.0 Firefox/41.0

First Broken 
Environmental Variables:
Device: Flame 3.0
BuildID: 20150519030124
Gaia: 97dc139f1a690224e98533a86526c4165eed1db5
Gecko: 4fb7ff694bf5
Gonk: Could not pull gonk.  Did you shallow Flash?
Version: 41.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:41.0) Gecko/41.0 Firefox/41.0

Last Working gaia / First Broken gecko - Issue DOES occur
Gaia: 762cbd16712484f93f485e89f5363686540a3db7
Gecko: 4fb7ff694bf5

First Broken gaia / Last Working gecko - Issue does NOT occur
Gaia: 97dc139f1a690224e98533a86526c4165eed1db5
Gecko: f65cc0022a0e

Gecko Pushlog: http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=f65cc0022a0e&tochange=4fb7ff694bf5
This issue has a much lower reproduction rate the further back into Mozilla Inbound I go the lower the reproduction rate for this issue becomes.

The earliest build I was able to reproduce this issue on is below, however that took me 20 minutes to reproduce whereas more recent builds I can consistently reproduce within 3 minutes.  Because the repro rate drops so significantly I'm also not sure that the central window above is valid either.  Removing the window tag because the repro rate is too low.

Environmental Variables:
Device: Flame 3.0
BuildID: 20150517090944
Gaia: afea16de7a76c3b6d15c35fb4c37bac71c8ddc6a
Gecko: 35918b0441b4
Version: 41.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:41.0) Gecko/41.0 Firefox/41.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: regressionwindow-wanted
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Master have since changed a lot on this part -- qawanted to see if still reproduced.
Keywords: qawanted
I spent some time trying to reproduce this on today's Nightly Flame build with no luck.

Environmental Variables:
Device: Flame 2.5
BuildID: 20150707010204
Gaia: e6506d68e01489b57616f8b74e8773f938ce62b3
Gecko: e7e69cc8c07b
Gonk: a4f6f31d1fe213ac935ca8ede7d05e47324101a4
Version: 42.0a1 (2.5) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:42.0) Gecko/42.0 Firefox/42.0
Flags: needinfo?(timdream)
Keywords: qawanted
Comment hidden (obsolete)
Comment hidden (obsolete)
No longer reproducible per comment 5.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
status-b2g-master: affected → fixed
Flags: needinfo?(timdream)
Resolution: --- → FIXED
This issue is verified as no longer occurring on Flame and Aries. Following STR, Homescreen is not revealed in the word suggestion bar when transitioning input between SSID Network Name and Password fields. Bug repro rate is 0 out of 10 attempts on each branch/device.

Verified on:
Device: Aries 2.6
BuildID: 20151123143009
Gaia: bae13c9ac6a91beecd7c94384e2aef25ed1a3214
Gecko: d3d286102ba7f8801e9dfe12d534f49554ba50c0
Gonk: a19052e4389c3ae2d8fc3e7a74a475401baacc56
Version: 45.0a1 (2.6) 
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:45.0) Gecko/45.0 Firefox/45.0

Device: Flame 2.5
BuildID: 20151123163948
Gaia: 5839f17dedc757947c9531dc0d66c3c49119f5ea
Gecko: 3a45ca93dd447e046baa2c7590f60ae008e438f8
Gonk: 205ac4204bbbb2098a8046444acba551ba5dc75a
Version: 44.0a2 (2.5) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0

Device: Flame 2.6
BuildID: 20151123142444
Gaia: bae13c9ac6a91beecd7c94384e2aef25ed1a3214
Gecko: d3d286102ba7f8801e9dfe12d534f49554ba50c0
Gonk: 205ac4204bbbb2098a8046444acba551ba5dc75a
Version: 45.0a1 (2.6) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:45.0) Gecko/45.0 Firefox/45.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
status-b2g-v2.5: --- → verified
status-b2g-master: fixed → verified
Flags: needinfo?(jmercado)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmercado)
You need to log in before you can comment on or make changes to this bug.