[e10s] Crash while trying to upload images on Facebook only

RESOLVED DUPLICATE of bug 1166742

Status

()

Firefox
Untriaged
--
critical
RESOLVED DUPLICATE of bug 1166742
3 years ago
2 years ago

People

(Reporter: Apophis99942, Unassigned)

Tracking

({crash, regression, reproducible})

41 Branch
crash, regression, reproducible
Points:
---

Firefox Tracking Flags

(firefox40 unaffected, firefox41 ?)

Details

(crash signature)

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:41.0) Gecko/20100101 Firefox/41.0
Build ID: 20150519030202

Steps to reproduce:

try to upload an image on facebook and it will crash.

I am using Firefox Nightly 41


Actual results:

browser tab crashes, see my bug details:

https://crash-stats.mozilla.com/report/index/8577eefa-18dc-4a0f-925f-0714b2150520

https://crash-stats.mozilla.com/report/index/4666eed4-1e97-4900-a824-590032150520

https://crash-stats.mozilla.com/report/index/04e9222a-79e8-4186-b9fd-8a78f2150520

https://crash-stats.mozilla.com/report/index/93ee7bdb-5801-4d32-8409-325092150520
(Reporter)

Updated

3 years ago
Severity: normal → major
Priority: -- → P1

Comment 1

3 years ago
I guess e10s was enabled?
Severity: major → critical
Flags: needinfo?(milfferrari)
Keywords: crash
Priority: P1 → --
(Reporter)

Comment 2

3 years ago
Yes it was, today's morning i did the following test:

Check if the browser had e10s enabled, and it was!

Disabled all the extensions i had in use

Restart Nightly in Safe Mode (No Refresh)

Went on Facebook and re-checked for the issue

My Firefox didn't crashed yet.

So i assure it was one of the installed extensions that blocked the multi-process..

I have the following extensions: 

AdBlock, Cookie Importer/Exporter, HackBar, Firebug.. (*)

(*) Later i will give you the whole list name. They are all updated to their latest version.
Flags: needinfo?(milfferrari)

Comment 3

3 years ago
Mozilla/5.0 (Windows NT 6.3; WOW64; rv:41.0) Gecko/20100101 Firefox/41.0
Build ID: 20150520030205

I get a different crash signature from uploading images to Facebook in my main profile.
https://crash-stats.mozilla.com/report/index/d5912ea1-9f9c-4213-b4d6-07dfd2150521
https://crash-stats.mozilla.com/report/index/6e534a93-9227-4d05-8d1c-dac9f2150521
https://crash-stats.mozilla.com/report/index/f60d01bc-3b9c-407f-89b5-d474f2150521

The crash occurs after I click the Open button from the file explorer window when I try to upload one or more images at once.
(Reporter)

Comment 4

3 years ago
(In reply to Fanolian from comment #3)
> Mozilla/5.0 (Windows NT 6.3; WOW64; rv:41.0) Gecko/20100101 Firefox/41.0
> Build ID: 20150520030205
> 
> I get a different crash signature from uploading images to Facebook in my
> main profile.
> https://crash-stats.mozilla.com/report/index/d5912ea1-9f9c-4213-b4d6-
> 07dfd2150521
> https://crash-stats.mozilla.com/report/index/6e534a93-9227-4d05-8d1c-
> dac9f2150521
> https://crash-stats.mozilla.com/report/index/f60d01bc-3b9c-407f-89b5-
> d474f2150521
> 
> The crash occurs after I click the Open button from the file explorer window
> when I try to upload one or more images at once.

We have the same problem but with different crash signatures, have you tried what i have done (to disable the extensions) does it crash also when you disable them?
(Reporter)

Updated

3 years ago
Crash Signature: https://crash-stats.mozilla.com/report/index/8577eefa-18dc-4a0f-925f-0714b2150520 https://crash-stats.mozilla.com/report/index/4666eed4-1e97-4900-a824-590032150520 https://crash-stats.mozilla.com/report/index/04e9222a-79e8-4186-b9fd- 8a78f215…
Keywords: 64bit
(Reporter)

Updated

3 years ago
Summary: Crash while starting an upload on facebook only → Crash while trying to upload images on facebook only

Comment 5

3 years ago
I did a couple of tests in a brand new profile (not in safe mode) but all get the same crash signature as my main profile does.

Can you edit the crash signature field to
[@ nsHtml5RefPtr<nsHtml5StreamParser>::nsHtml5RefPtr<nsHtml5StreamParser>(nsHtml5StreamParser*) ]
[@ nsCOMPtr<nsIDOMElement>::nsCOMPtr<nsIDOMElement>(nsIDOMElement*) | `anonymous namespace''::SimpleEnumerator::GetNext(nsISupports**) ]

(2 different crash signatures on separate lines)
This should be the proper format. I don't have the permission to edit your report.

Comment 6

3 years ago
My Nightly is 32bit a in 64bit Windows fwiw.
(Reporter)

Comment 7

3 years ago
Okay! i will update it
(Reporter)

Updated

3 years ago
Crash Signature: https://crash-stats.mozilla.com/report/index/8577eefa-18dc-4a0f-925f-0714b2150520 https://crash-stats.mozilla.com/report/index/4666eed4-1e97-4900-a824-590032150520 https://crash-stats.mozilla.com/report/index/04e9222a-79e8-4186-b9fd- 8a78f215&hellip; → [@ nsHtml5RefPtr<nsHtml5StreamParser>::nsHtml5RefPtr<nsHtml5StreamParser>(nsHtml5StreamParser*) ] [@ nsCOMPtr<nsIDOMElement>::nsCOMPtr<nsIDOMElement>(nsIDOMElement*) | `anonymous namespace''::SimpleEnumerator::GetNext(nsISupports**) ]
Keywords: 64bit

Comment 8

3 years ago
It crashes when I try to upload any types of files on Google Drive. More like a file handling issue?
(Reporter)

Comment 9

3 years ago
Yes i think, didn't tested on other websites.
May someone be in touch with it (any dev or project admin)?

Comment 10

3 years ago
I think it's an issue with the File Picker, when the user try to add a 2nd file when the 1st one is uploading, FF crashes.
Blocks: 516752
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: reproducible
Summary: Crash while trying to upload images on facebook only → [e10s] Crash while trying to upload images on Facebook only

Comment 11

3 years ago
It's a recent regression.
good=2015-05-18
bad=2015-05-19
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=35918b0441b4&tochange=4fb7ff694bf5


I got a different crash signature linked to bug 1166742
https://crash-stats.mozilla.com/report/index/be17add6-858a-40cd-bd9e-c3d462150521

But bug 1166742 is restricted.
status-firefox40: --- → unaffected
status-firefox41: --- → ?
Keywords: regression
(Reporter)

Comment 12

3 years ago
(In reply to Loic from comment #11)
> It's a recent regression.
> good=2015-05-18
> bad=2015-05-19
> http://hg.mozilla.org/mozilla-central/
> pushloghtml?fromchange=35918b0441b4&tochange=4fb7ff694bf5
> 
> 
> I got a different crash signature linked to bug 1166742
> https://crash-stats.mozilla.com/report/index/be17add6-858a-40cd-bd9e-
> c3d462150521
> 
> But bug 1166742 is restricted.

That crash is the same as mine or has been caused by another factor?

Comment 13

3 years ago
Fixed in 05-21 Nightly, perhaps by bug 1166742.

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1166742

Comment 15

2 years ago
Unfortunately the bug 1166742 is private. Is there a way I can see its contents? I'm seeing the same problem and I'd like to test any patches.
(In reply to Dâniel Fraga from comment #15)
> Unfortunately the bug 1166742 is private. Is there a way I can see its
> contents? I'm seeing the same problem and I'd like to test any patches.

I've unhidden the bug now, but it was patched back in May, so if you are still seeing similar issues to this bug, please file a new bug.
You need to log in before you can comment on or make changes to this bug.