Closed Bug 1166943 Opened 5 years ago Closed 2 years ago

[Edge Gesture] Wallpaper is shown during edge gesture between apps

Categories

(Firefox OS Graveyard :: Gaia::System::Window Mgmt, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(b2g-v2.2 unaffected, b2g-master affected)

RESOLVED WONTFIX
Tracking Status
b2g-v2.2 --- unaffected
b2g-master --- affected

People

(Reporter: ychung, Unassigned)

References

()

Details

(Keywords: regression, Whiteboard: [3.0-Daily-Testing][systemsfe])

Attachments

(1 file)

Description:
When switching between apps by edge gesture, wallpaper is shown in the background. This issue might not appear at first, but I could easily see the wallpaper after switching between apps a few times.

Repro Steps:
1) Update a Flame to 20150520010202
2) Open multiple apps, such as Browser, Contacts, Messages, Email, etc.
3) Switch between apps by edge gesture several times.
4) Observe the gap between apps in the background.

Actual:
Wallpaper is shown.

Expected:
Only black background is shown on the gaps.

Environmental Variables:
Device: Flame 3.0 (KK, 319mb, full flash)
Build ID: 20150520010202
Gaia: 600fd8249960b8256af9de67d9171025bb9a3ff3
Gecko: ac277e615f8f
Gonk: 040bb1e9ac8a5b6dd756fdd696aa37a8868b5c67
Version: 41.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:41.0) Gecko/41.0 Firefox/41.0

Repro frequency: 6/7
See attached: video clip, logcat
https://youtu.be/myys1BFpQM0
This issue does NOT reproduces on Flame 2.2.

Result: Only black background is shown during edge gesture.

Environmental Variables:
Device: Flame 2.2 (KK, 319mb, full flash)
Build ID: 20150520002502
Gaia: 63e9eeec3032318f8a240f80b6a184fa4b50b6e1
Gecko: a89755309dea
Gonk: bd9cb3af2a0354577a6903917bc826489050b40d
Version: 37.0 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
QA Contact: pcheng
mozilla-inbound regression window:

Last Working
Device: Flame
BuildID: 20150517090944
Gaia: afea16de7a76c3b6d15c35fb4c37bac71c8ddc6a
Gecko: 35918b0441b4
Version: 41.0a1 (3.0 Master)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:41.0) Gecko/41.0 Firefox/41.0

First Broken
Device: Flame
BuildID: 20150517145844
Gaia: afea16de7a76c3b6d15c35fb4c37bac71c8ddc6a
Gecko: c4a454c2b1c3
Version: 41.0a1 (3.0 Master)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:41.0) Gecko/41.0 Firefox/41.0

Gaia is the same so it's a Gecko issue.

Gecko pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=35918b0441b4&tochange=c4a454c2b1c3

Possibly caused by patches for Bug 1157030.
Blocks: 1157030
Flags: needinfo?(ktucker)
Gabriele, can you take a look at this please? This looks to have been caused by the landing for bug 1157030.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker) → needinfo?(gsvelto)
I'll have a look but this is rather peculiar. Bug 1157030 hasn't touched anything related to graphics, layout or compositing so I'm unsure how it might be causing a visible artifact.
I've just tested this with gaia 655ecfd48bf67156c36ffacd74441e03a48524c1 and gecko 14245f685eb94baad602e4a849aa47e6f7433073 but can't reproduce. I've tested on a Flame with memory set to 319MB. The bars between apps are always black. I've tried swiping a few dozens of times both normally and very fast but it doesn't seem to make a difference.
Flags: needinfo?(gsvelto)
This doesn't happen right away, but once it starts happening it happens every time. I've tested on today's 3.0 nightly and it is still occurring. I've found that sometimes let the phone fall asleep and wake it up seems(?) to help with reproducing. I have Phone, Messages, Contacts, and Settings apps opened. I swipe slowly but not sure if it makes a difference.
Flags: needinfo?(pbylenga)
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][Low_QA]
Firefox OS is not being worked on
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.