Please deploy autopush 1.2.1 to stage

VERIFIED FIXED

Status

VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: benbangert, Assigned: oremj)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
This fixes a regression in 1.2.0. 

Last stage deploy was 1.2.0.
Last production deploy was 1.1rc2

Following are complete set of changes since prior production deploy.

1.2.1 (May 20, 2015)
====================

Bug Fixes
---------
* Fix error with blank UAIDs being rejected as "already registered"

1.2.0 (May 19, 2015)
====================

Features
--------

* Pong delay can no longer be set, and uses an adaptive value based on the last
  ping to try and accurately compensate for higher latency connections. This
  also removes the min_ping_interval option such that if a client is pinging
  too frequently we will instead leave space for up to the clients timeout of
  10-sec (a hardcoded client value).

Bug Fixes
---------

* Fix 500 errors in endpoint caused by timeouts when trying to deliver to
  expired nodes in the cluster. Resolves Issue #75.
* Add CancelledError trap to all deferreds in websocket.py. Resolves Issue #74.
* Aggressively delete old TCP connections on device reregistration (#72)

Backwards Incompatibility
-------------------------

* Removed min_ping_interval config option.
* Removed pong_delay config option.
(Reporter)

Updated

4 years ago
Assignee: nobody → oremj
(Assignee)

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
I was able to ring and locate a Flame pointed at `stage`.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.