If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

inconsistent mouse wheel scrolling behaviour on advanced system panel

RESOLVED FIXED

Status

SeaMonkey
Preferences
--
minor
RESOLVED FIXED
16 years ago
13 years ago

People

(Reporter: Paul Wilkins, Assigned: Brian Ryner (not reading))

Tracking

({qawanted})

Trunk
x86
All
qawanted

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:0.9.7) Gecko/20011221
BuildID:    2001122106

On the System panel of the Advanced preferences, both scrollable windows scroll
at the same time when a tickbox is currently active in one window and you use
the mouse scroll wheel in the other window.

Reproducible: Always
Steps to Reproduce:
1. Navigate to Edit > Preferences > Advanced > System
2. In one of the two scrollable windows, click on one of the tick boxes
3. Move the mouse to the other scrollable window and use the mouse wheel to
scroll up and down

Actual Results:  Both of the scrollable windows scroll at the same time.


Expected Results:  Only the window under the mouse pointer should scroll. The
window with the active tickbox should not scroll unless the mouse is over that
window.

Comment 1

16 years ago
Yup.  Win98SE bog-standard MS wheelmouse+drivers 0.9.7/2001122106, confirming.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

16 years ago
Mousewheel + focus-ish: over to bryner for a look.
Assignee: sgehani → bryner
Keywords: qawanted

Updated

16 years ago
OS: Windows 98 → All

Comment 3

16 years ago
*** Bug 127583 has been marked as a duplicate of this bug. ***

Comment 4

16 years ago
Hmm.  The relevant preferences panel has been amended, and now only one of these
boxes has a scrollbar.  Following the steps to reproduce to attempt to get that
one box to scroll, fails to do so.  So this problem doesn't exist any more (yay!).

(win98SE, 2002050406, 1.0 Branch)

->resolved fixed
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.