Closed Bug 1167021 Opened 5 years ago Closed 4 years ago

Call Tree total cost > 100%, total time > duration in non-inverted

Categories

(DevTools :: Performance Tools (Profiler/Timeline), defect, P2)

41 Branch
defect

Tracking

(firefox41 affected, firefox42 fixed)

RESOLVED FIXED
Firefox 42
Tracking Status
firefox41 --- affected
firefox42 --- fixed

People

(Reporter: jsantell, Assigned: jsantell)

References

Details

Attachments

(3 files)

Attached file totalcostweird.json
recording data to reproduce
Priority: -- → P2
One issue here is the profiler data is longer than timeline data by a second or so, so different results when nothing selected vs the entire graph selected.
Duplicate of this bug: 1172229
More info on recreating this in bug 1172229 -- due to recursion where a frame called multiple times in a sample is counted several times, increasing its total cost > total duration.

Possibly related to bug 1164325, which may be the same thing here.
See Also: → 1164325
Depends on: 1167899
I think bug 1177293 fixed this -- but should add tests for this, (and bug 1177293) to ensure that.
Depends on: 1177293
Assignee: nobody → jsantell
Status: NEW → ASSIGNED
Pulls out the cost logic into the model, rather than in the view, and add more tests for recursion and cost calculation -- covers the scenario in bug 1177239 as well with a test.

https://treeherder.mozilla.org/#/jobs?repo=try&revision=f0bd780427d2
Attachment #8633705 - Flags: review?(vporof)
Comment on attachment 8633705 [details] [diff] [review]
1167021-tree-model-cost.patch

Review of attachment 8633705 [details] [diff] [review]:
-----------------------------------------------------------------

Very cool, I wanted to do this too.
Attachment #8633705 - Flags: review?(vporof) → review+
https://hg.mozilla.org/mozilla-central/rev/d2daa6751884
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Target Milestone: --- → Firefox 42
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.