If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Overwrite BLE related flags to enable BLE functionalities in bluedroid for both bluetooth1 and bluetooth2

RESOLVED FIXED

Status

Firefox OS
Bluetooth
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: jocelyn, Assigned: jocelyn)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(firefox41 fixed)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Assignee)

Description

2 years ago
Currently bluetooth1 and bluetooth2 share the same b2g_bdroid_buildcfg.h under bluetooth/bluedroid, and BLE related flags are overwritten manually by developers who wants to use bluetooth2 with GATT API.

After several test rounds done by QA and bluetooth team members, we didn't see any side effect on classic bluetooth functions caused by enabling BLE functionalities in bluedroid.

IMHO, we're ready to enable BLE functionalities in bluedroid for both bluetooth1 and bluetooth2 now.
I'd suggest to move this header file into bluetoothd's repository.
(In reply to Thomas Zimmermann [:tzimmermann] [:tdz] from comment #1)
> I'd suggest to move this header file into bluetoothd's repository.

OK, that's actually a different bug. We discussed this a bit on IRC and it's something we want to do after having moved away from HAL.
(Assignee)

Comment 3

2 years ago
Created attachment 8608638 [details] [diff] [review]
Bug 1167070: Overwrite BLE related flags to enable BLE functionalities in bluedroid for both bluetooth1 and bluetooth2.

Hi Shawn,

Could you help to review my patch.

Thanks,
Jocelyn
Attachment #8608638 - Flags: review?(shuang)
Attachment #8608638 - Flags: review?(shuang) → review+
\0/
(Assignee)

Comment 5

2 years ago
Created attachment 8609710 [details] [diff] [review]
[Final] Bug 1167070: Overwrite BLE related flags to enable BLE functionalities in bluedroid for both bluetooth1 and bluetooth2. r=shuang

try: https://treeherder.mozilla.org/#/jobs?repo=try&revision=27eb8326899d
Attachment #8608638 - Attachment is obsolete: true
(Assignee)

Updated

2 years ago
Keywords: checkin-needed

Comment 6

2 years ago
https://hg.mozilla.org/integration/b2g-inbound/rev/4fbe8dbf3a35
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/4fbe8dbf3a35
Status: NEW → RESOLVED
Last Resolved: 2 years ago
status-firefox41: --- → fixed
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.