If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Bad include breaks build on case-sensitive Mac filesystems

RESOLVED FIXED

Status

()

Core
XUL
--
blocker
RESOLVED FIXED
16 years ago
16 years ago

People

(Reporter: Matt Watson, Assigned: Simon Fraser)

Tracking

Trunk
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
qfx/src/mac/nsRegionPool.h, nsImageMac.cpp, 
nsRenderingContextMac.cpp, nsRegionMac.h, nsDeviceContextMac.h 
have:

#include <QuickDraw.h>

instead of

#include <Quickdraw.h>

This breaks the build on case-sensitive filesystems, like NFS or UFS
(Reporter)

Comment 1

16 years ago
And nsIImageMac.h has:

#include <quickdraw.h>

Comment 2

16 years ago
mgw, care to make a patch for the mozilla trunk that we can checkin?
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 3

16 years ago
Sure, once I find them all:

nsWatchTypes.h has:

#include "PRTypes.h"

instead of

#include "prtypes.h"
(Reporter)

Comment 4

16 years ago
Here's a diff. I'm not sure which patch format to use, but this should be 
parseable.

Index: gfx/src/mac/nsDeviceContextMac.h
=========================================================
==========
RCS file: /cvsroot/mozilla/gfx/src/mac/nsDeviceContextMac.h,v
retrieving revision 1.45
diff -w -u -b -r1.45 nsDeviceContextMac.h
--- gfx/src/mac/nsDeviceContextMac.h    2001/11/10 01:03:31     1.45
+++ gfx/src/mac/nsDeviceContextMac.h    2001/12/24 01:08:31
@@ -46,7 +46,7 @@
 #include "nsIRenderingContext.h"
 #include "nsIFontEnumerator.h"
 #include <Types.h>
-#include <QuickDraw.h>
+#include <Quickdraw.h>

 #include "nsIScreen.h"
 #include "nsIScreenManager.h"
Index: gfx/src/mac/nsIImageMac.h
=========================================================
==========
RCS file: /cvsroot/mozilla/gfx/src/mac/nsIImageMac.h,v
retrieving revision 1.3
diff -w -u -b -r1.3 nsIImageMac.h
--- gfx/src/mac/nsIImageMac.h   2001/09/26 00:15:26     1.3
+++ gfx/src/mac/nsIImageMac.h   2001/12/24 01:08:31
@@ -42,7 +42,7 @@


 #include "nsISupports.h"
-#include <quickdraw.h>
+#include <Quickdraw.h>

 // IID for the nsIImage interface
 // {80b2f600-f140-11d4-bb6f-d472847e8dbc}
Index: gfx/src/mac/nsImageMac.cpp
=========================================================
==========
RCS file: /cvsroot/mozilla/gfx/src/mac/nsImageMac.cpp,v
retrieving revision 1.40
diff -w -u -b -r1.40 nsImageMac.cpp
--- gfx/src/mac/nsImageMac.cpp  2001/09/26 00:15:26     1.40
+++ gfx/src/mac/nsImageMac.cpp  2001/12/24 01:08:34
@@ -41,7 +41,7 @@
 #include "nsCarbonHelpers.h"

 #include <MacTypes.h>
-#include <QuickDraw.h>
+#include <Quickdraw.h>

 #include "nsGfxUtils.h"

Index: gfx/src/mac/nsRegionMac.h
=========================================================
==========
RCS file: /cvsroot/mozilla/gfx/src/mac/nsRegionMac.h,v
retrieving revision 1.15
diff -w -u -b -r1.15 nsRegionMac.h
--- gfx/src/mac/nsRegionMac.h   2001/11/10 01:03:43     1.15
+++ gfx/src/mac/nsRegionMac.h   2001/12/24 01:08:34
@@ -40,7 +40,7 @@
 #define nsRegionMac_h___

 #include "nsIRegion.h"
-#include <QuickDraw.h>
+#include <Quickdraw.h>

 //------------------------------------------------------------------------

Index: gfx/src/mac/nsRegionPool.h
=========================================================
==========
RCS file: /cvsroot/mozilla/gfx/src/mac/nsRegionPool.h,v
retrieving revision 1.1
diff -w -u -b -r1.1 nsRegionPool.h
--- gfx/src/mac/nsRegionPool.h  2001/11/10 01:04:23     1.1
+++ gfx/src/mac/nsRegionPool.h  2001/12/24 01:08:34
@@ -40,7 +40,7 @@
 #define nsRegionPool_h___

 #include "nscore.h"
-#include <QuickDraw.h>
+#include <Quickdraw.h>


 class NS_EXPORT nsNativeRegionPool
Index: gfx/src/mac/nsRenderingContextMac.cpp
=========================================================
==========
RCS file: /cvsroot/mozilla/gfx/src/mac/nsRenderingContextMac.cpp,v
retrieving revision 1.134
diff -w -u -b -r1.134 nsRenderingContextMac.cpp
--- gfx/src/mac/nsRenderingContextMac.cpp       2001/12/15 02:31:47     
1.134
+++ gfx/src/mac/nsRenderingContextMac.cpp       2001/12/24 01:08:37
@@ -58,7 +58,7 @@

 #include <FixMath.h>
 #include <Gestalt.h>
-#include <QuickDraw.h>
+#include <Quickdraw.h>

 #include "nsRegionPool.h"
 #include "nsFontUtils.h"
Index: gfx/src/mac/nsWatchTask.h
=========================================================
==========
RCS file: /cvsroot/mozilla/gfx/src/mac/nsWatchTask.h,v
retrieving revision 1.5
diff -w -u -b -r1.5 nsWatchTask.h
--- gfx/src/mac/nsWatchTask.h   2001/10/27 07:37:40     1.5
+++ gfx/src/mac/nsWatchTask.h   2001/12/24 01:08:38
@@ -45,7 +45,7 @@
 #include <Retrace.h>
 #endif
 #include <Quickdraw.h>
-#include "PRTypes.h"
+#include "prtypes.h"
 #include "nscore.h"


RCS file: /cvsroot/mozilla/widget/src/mac/nsAppShell.cpp,v
retrieving revision 1.42
diff -w -u -b -r1.42 nsAppShell.cpp
--- widget/src/mac/nsAppShell.cpp       2001/11/29 15:39:33     1.42
+++ widget/src/mac/nsAppShell.cpp       2001/12/24 01:10:21
@@ -51,7 +51,7 @@
 #include "nsIServiceManager.h"
 #include "nsIWidget.h"
 #include "nsMacMessagePump.h"
-#include "nsToolKit.h"
+#include "nsToolkit.h"
 #include <Quickdraw.h>
 #include <Fonts.h>
 #include <TextEdit.h>
Index: widget/src/mac/nsMacWindow.cpp
=========================================================
==========
RCS file: /cvsroot/mozilla/widget/src/mac/nsMacWindow.cpp,v
retrieving revision 1.109
diff -w -u -b -r1.109 nsMacWindow.cpp
--- widget/src/mac/nsMacWindow.cpp      2001/11/29 22:36:19     1.109
+++ widget/src/mac/nsMacWindow.cpp      2001/12/24 01:10:25
@@ -49,7 +49,7 @@
 #include "nsIScreenManager.h"
 #include "nsGUIEvent.h"
 #include "nsCarbonHelpers.h"
-#include "nsGFXUtils.h"
+#include "nsGfxUtils.h"
 #include "DefProcFakery.h"
 #include "nsMacResources.h"
 #include "nsRegionMac.h"
Index: widget/src/mac/nsMenuX.cpp
=========================================================
==========
RCS file: /cvsroot/mozilla/widget/src/mac/nsMenuX.cpp,v
retrieving revision 1.31
diff -w -u -b -r1.31 nsMenuX.cpp
--- widget/src/mac/nsMenuX.cpp  2001/12/17 10:16:37     1.31
+++ widget/src/mac/nsMenuX.cpp  2001/12/24 01:10:28
@@ -46,7 +46,7 @@
 #include "prinrval.h"

 #include "nsMenuX.h"
-#include "nsMenubarX.h"
+#include "nsMenuBarX.h"
 #include "nsIMenu.h"
 #include "nsIMenuBar.h"
 #include "nsIMenuItem.h"
Index: widget/src/mac/nsWindow.h
=========================================================
==========
RCS file: /cvsroot/mozilla/widget/src/mac/nsWindow.h,v
retrieving revision 1.87
diff -w -u -b -r1.87 nsWindow.h
--- widget/src/mac/nsWindow.h   2001/09/28 20:11:24     1.87
+++ widget/src/mac/nsWindow.h   2001/12/24 01:10:29
@@ -52,7 +52,7 @@
 #include "nsIMenuBar.h"

 #include "nsplugindefs.h"
-#include <QuickDraw.h>
+#include <Quickdraw.h>

 #define NSRGB_2_COLOREF(color) \
             RGB(NS_GET_R(color),NS_GET_G(color),NS_GET_B(color))

Comment 5

16 years ago
Matt can you attach that diff to this bug, as opposed to pasting it in. Avoids 
accidental linebreaks from being inserted. 

sfraser: who should own this (gfx/widget mac modules) build issue.
Summary: Bad include breaks build on case-sensitive filesystems → Bad include breaks build on case-sensitive Mac filesystems
(Reporter)

Comment 6

16 years ago
Created attachment 62955 [details] [diff] [review]
Patch to make includes case-aware

This lets Mozilla build on Mac OS X when using a case-sensitive filesystem.
(Reporter)

Comment 7

16 years ago
The first few characters of that got mangled in transit. Delete all up to 
"index"
(Assignee)

Comment 8

16 years ago
I'll clean them up.
Assignee: hyatt → sfraser
(Reporter)

Comment 9

16 years ago
Actually, it's fine if you download the attachment, it just looks like some 
characters got inserted when you view it in the browser (macbinary?)

Updated

16 years ago
Blocks: 108300
(Assignee)

Comment 10

16 years ago
Patches checked in.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.