[Window Management] At Enter PIN view, if you tap screen several times, current view is not in full screen, and part view of lower layer can be seen.

RESOLVED DUPLICATE of bug 1133029

Status

defect
RESOLVED DUPLICATE of bug 1133029
4 years ago
4 years ago

People

(Reporter: wangxiaomei, Assigned: apastor)

Tracking

unspecified
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.2 affected, b2g-master unaffected)

Details

(Whiteboard: [v2.2-nexus-5-l][systemsfe])

Attachments

(2 attachments)

Reporter

Description

4 years ago
Posted file logcat_1502.txt
[1.Description]:
[Flame v2.2][Nexus5 v2.2][Window Management] After rebooting the test device, tap to open a notification [EX:Take a screenshort] from lockscreen. It will go to Enter PIN view. If you tap screen several times at this view, this current view will not be in full screen then, and part view of lower layer can be seen from bottom location.
Time:15:02
See attachment logcat_1502.txt and 1502.mp4

[2.Testing Steps]: 
Precondition:The test device have a PIN code.
1.Have a notification.[EX:Take a screenshort]
2.Reboot the test device.
3.Open the screenshort from lockscreen.
4.Tap blank area in current page several times.


[3.Expected Result]: 
4.Curren view is in full screen, and lower layer can not be seen.

[4.Actual Result]: 
4.Current view is not in full screen, and part view of lower layer can be seen from bottom location.

[5.Reproduction build]: 
Flame 2.2 version(Affected):
Build ID               20150520162503
Gaia Revision          bc42fbc12d622bffd7e8afcb8d56f8a1d9773c60
Gaia Date              2015-05-20 22:32:56
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/8663598512f7
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150520.195701
Firmware Date          Wed May 20 19:57:10 EDT 2015
Bootloader             L1TC000118D0

Flame 3.0 version(Unaffected):
Build ID               20150520160208
Gaia Revision          b290c77ccb7ab0af599b3d8287b71b9970d8dcb0
Gaia Date              2015-05-20 10:19:05
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/8d8df22fe72d
Gecko Version          41.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150520.192608
Firmware Date          Wed May 20 19:26:18 EDT 2015
Bootloader             L1TC000118D0

Nexus5 2.2 version(Affected):
Build ID               20150520162503
Gaia Revision          bc42fbc12d622bffd7e8afcb8d56f8a1d9773c60
Gaia Date              2015-05-20 22:32:56
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/8663598512f7
Gecko Version          37.0
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150520.193900
Firmware Date          Wed May 20 19:39:15 EDT 2015
Bootloader             HHZ12f

Nexus5 3.0 version(Unaffected):
Build ID               20150520160208
Gaia Revision          b290c77ccb7ab0af599b3d8287b71b9970d8dcb0
Gaia Date              2015-05-20 10:19:05
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/8d8df22fe72d
Gecko Version          41.0a1
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150520.191346
Firmware Date          Wed May 20 19:14:00 EDT 2015
Bootloader             HHZ12f

[6.Reproduction Frequency]: 
occasionally Recurrence,9/10

[7.TCID]: 
Free Test
Reporter

Comment 1

4 years ago
Posted video 1502.mp4
Reporter

Updated

4 years ago
QA Contact: jthomas
mozilla-b2g37_v2_2-flame-kk-eng Regression Window:

Unable to provide an inbound window as the 2.2 build window does not exist.

This appears to be a Gaia issue.

Last Working 
Environmental Variables:
Device: Flame 2.2
Build ID: 20150407140912
Gaia: 4a5b6f8e8b724c9525b16020bbe83a3d74930630
Gecko: d40ebc8e0642
Version: 37.0 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

First Broken 
Environmental Variables:
Device: Flame 2.2
BuildID: 20150407143112
Gaia: ea735c21bfb0d78333213ff0376fce1eac89ead6
Gecko: 3f86ddb7f719
Version: 37.0 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

Last Working gaia / First Broken gecko - Issue does NOT reproduce 
Gaia 4a5b6f8e8b724c9525b16020bbe83a3d74930630 
Gecko: 3f86ddb7f719

First Broken gaia / Last Working gecko - Issue DOES reproduce
Gaia: ea735c21bfb0d78333213ff0376fce1eac89ead6
Gecko: 3f86ddb7f719

Gaia Pushlog: https://github.com/mozilla-b2g/gaia/compare/%3C4a5b6f8e8b724c9525b16020bbe83a3d74930630%20%3E%3Cea735c21bfb0d78333213ff0376fce1eac89ead6%3E

Issue appears to have been caused by changes made in bug 1149114
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage-]
Flags: needinfo?(ktucker) → needinfo?(jthomas)
QA Whiteboard: [QAnalyst-Triage-] → [QAnalyst-Triage?]
Flags: needinfo?(jthomas) → needinfo?(ktucker)
Here is the correct pushlog:
https://github.com/mozilla-b2g/gaia/compare/4a5b6f8e8b724c9525b16020bbe83a3d74930630...ea735c21bfb0d78333213ff0376fce1eac89ead6

Alberto, can you take a look at this please? This looks to have been caused by the work done for bug 1149114.
Blocks: 1149114
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker) → needinfo?(apastor)
Whiteboard: [v2.2-nexus-5-l] → [v2.2-nexus-5-l][systemsfe]
blocking-b2g: --- → 2.2?
Assignee

Updated

4 years ago
Assignee: nobody → apastor
Flags: needinfo?(apastor)
Assignee

Updated

4 years ago
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1133029
blocking-b2g: 2.2? → 2.2+
You need to log in before you can comment on or make changes to this bug.