Use Java 1.8 in socorro-infra

RESOLVED FIXED

Status

RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: dmaher, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
Java 1.7 is EOL[1], and the official ES 1.4 documentation[0] suggests using Java 1.8 - I therefore propose that we move to 1.8 in AWS.  Any objections? :)


[0] https://www.elastic.co/guide/en/elasticsearch/reference/1.4/_installation.html
[1] http://www.oracle.com/technetwork/java/eol-135779.html
(Reporter)

Updated

4 years ago
Flags: needinfo?(rhelmer)
No objections from me, this is the only Socorro-related service that uses Java AFAIK so should be fine to upgrade.
Flags: needinfo?(rhelmer)
(Reporter)

Comment 2

4 years ago
Splendid. I've got this wrapped into the upcoming ES PR.
(Reporter)

Comment 4

4 years ago
Resolved in #132 (above).
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.