Graphene doesn't auto update anymore

RESOLVED FIXED

Status

Firefox OS
Runtime
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: paul, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
With: http://ftp.mozilla.org/pub/mozilla.org/b2g/nightly/2015-05-18-04-42-05-larch/
Knowing that there's a build for the day after: http://ftp.mozilla.org/pub/mozilla.org/b2g/nightly/2015-05-19-04-42-07-larch/
… with mar files.

update.xml is empty: https://aus4.mozilla.org/update/3/Graphene/41.0a1/20150518044205/Darwin_x86_64-gcc3/en-US/default/Darwin%2014.4.0/default/default/update.xml?force=1

Logs:

*** AUS:SVC Checker: checkForUpdates, force: true
*** AUS:SVC getLocale - getting locale from file: resource://app/update.locale, locale: en-US
*** AUS:SVC Checker:getUpdateURL - update URL: https://aus4.mozilla.org/update/3/Graphene/41.0a1/20150518044205/Darwin_x86_64-gcc3/en-US/default/Darwin%2014.4.0/default/default/update.xml?force=1
*** AUS:SVC gCanCheckForUpdates - able to check for updates
*** AUS:SVC Checker:checkForUpdates - sending request to: https://aus4.mozilla.org/update/3/Graphene/41.0a1/20150518044205/Darwin_x86_64-gcc3/en-US/default/Darwin%2014.4.0/default/default/update.xml?force=1
XXX FIXME : Got a mozContentEvent: force-update-check
*** AUS:SVC Checker:onLoad - request completed downloading document
*** AUS:SVC Checker:onLoad - number of updates available: 0
*** AUS:SVC UpdateManager:_loadXMLFileIntoArray: XML file does not exist
Ben, can you check what's happening? Thanks!
Flags: needinfo?(bhearsum)
There's at least two issues with nightlies that I see that they're all failing on https://treeherder.mozilla.org/#/jobs?repo=larch. 

The 64-bit Windows build regularly times out when trying to generate a profile for PGO - I suggest taking this to another bug
06:33:21     INFO -  MOZ_PGO_INSTRUMENTED=1 JARLOG_FILE=jarlog/en-US.log EXTRA_TEST_ARGS=10 c:/builds/moz2_slave/l-w64_graphene-ntly-0000000000/build/src/mozmake.EXE -C c:/builds/moz2_slave/l-w64_graphene-ntly-0000000000/build/src/obj-graphene pgo-profile-run
06:33:21     INFO -  mozmake.EXE[2]: Entering directory 'c:/builds/moz2_slave/l-w64_graphene-ntly-0000000000/build/src/obj-graphene'
06:33:21     INFO -  c:/builds/moz2_slave/l-w64_graphene-ntly-0000000000/build/src/obj-graphene/_virtualenv/Scripts/python.exe c:/builds/moz2_slave/l-w64_graphene-ntly-0000000000/build/src/build/pgo/profileserver.py 10
07:53:22     INFO - Automation Error: mozprocess timed out after 4800 seconds running ['c:\\mozilla-build\\python27\\python.exe', 'mach', '--log-no-times', 'build', '-v']
07:53:22    ERROR - timed out after 4800 seconds of no output



The 64-bit Linux build fails when trying to submit data to Balrog:
07:01:09     INFO -  "PUT /api/releases/Graphene-larch-nightly-20150518044205/builds/Linux_x86_64-gcc3/en-US HTTP/1.1" 401 85
07:01:09     INFO -  Caught HTTPError: stage-b2gbld is not allowed to access /releases/:name/builds/:platform/:locale by PUT
07:00:57     INFO -  "PUT /api/releases/Graphene-larch-nightly-20150518044205/builds/Linux_x86_64-gcc3/en-US HTTP/1.1" 401 79
07:00:57     INFO -  Caught HTTPError: b2gbld is not allowed to access /releases/:name/builds/:platform/:locale by PUT



It looks to me like we used to submit as ffxbld, so this is a regression. It broke around March 20th, which lines up with bug 1143910. Rail, can you have a look?
Flags: needinfo?(bhearsum) → needinfo?(rail)
http://hg.mozilla.org/build/mozharness/file/ffac7c8aacda/configs/balrog/production.py#l9 has a product-to-balrog-username mapping. According to the log, product is set to "b2g".

We should either change the product value to "graphene" or grant b2gbld enough privileges.
Flags: needinfo?(rail)
(In reply to Rail Aliiev [:rail] from comment #3)
> http://hg.mozilla.org/build/mozharness/file/ffac7c8aacda/configs/balrog/
> production.py#l9 has a product-to-balrog-username mapping. According to the
> log, product is set to "b2g".
> 
> We should either change the product value to "graphene" or grant b2gbld
> enough privileges.

I don't have any opinion on this. Let's do what makes more sense on your side!
(In reply to Rail Aliiev [:rail] from comment #3)
> http://hg.mozilla.org/build/mozharness/file/ffac7c8aacda/configs/balrog/
> production.py#l9 has a product-to-balrog-username mapping. According to the
> log, product is set to "b2g".
> 
> We should either change the product value to "graphene" or grant b2gbld
> enough privileges.

Alright, I adjusted the permissions so that *b2gbld has Graphene accounts and *ffxbld no longer does. I seem to recall thinking that ffxbld was a better choice, but considering we upload /pub/mozilla.org/b2g, it probably doesn't matter. After the next set of nightlies runs (requires a new push first) Graphene nightlies should receive updates again.


Another thing I noticed just now, the request in comment #0 looks like it's from an on-change build, which explicitly does not receive updates. Paul, you'll want to download a Nightly from http://ftp.mozilla.org/pub/mozilla.org/b2g/nightly/latest-larch/ to receive updates after this is fixed.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.