Intermittent test_load_candidates.html | application crashed [@ mozilla::H264Converter::IsHardwareAccelerated()]

RESOLVED DUPLICATE of bug 1166288

Status

()

Core
Audio/Video
RESOLVED DUPLICATE of bug 1166288
3 years ago
3 years ago

People

(Reporter: Tomcat, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

3 years ago
Windows 7 32-bit mozilla-inbound pgo test mochitest-3

https://treeherder.mozilla.org/logviewer.html#?job_id=10038490&repo=mozilla-inbound

02:43:14 WARNING - PROCESS-CRASH | dom/media/test/test_load_candidates.html | application crashed [@ mozilla::H264Converter::IsHardwareAccelerated()]
02:43:14 INFO - Crash dump filename: c:\users\cltbld\appdata\local\temp\tmpum4afj.mozrunner\minidumps\cbeed83b-938a-4ea1-b779-b40e7709a486.dmp
02:43:14 INFO - Operating system: Windows NT
02:43:14 INFO - 6.1.7601 Service Pack 1
02:43:14 INFO - CPU: x86
02:43:14 INFO - GenuineIntel family 6 model 30 stepping 5
02:43:14 INFO - 8 CPUs
02:43:14 INFO - Crash reason: EXCEPTION_ACCESS_VIOLATION_READ
02:43:14 INFO - Crash address: 0x5a5a5a5a
02:43:14 INFO - Thread 72 (crashed)
02:43:14 INFO - 0 xul.dll!mozilla::H264Converter::IsHardwareAccelerated() [H264Converter.cpp:b46f7d0b2c4b : 115 + 0x0]
02:43:14 INFO - eip = 0x66a41b99 esp = 0x0883fc10 ebp = 0x0883fc34 ebx = 0x1713d000
02:43:14 INFO - esi = 0x1713d000 edi = 0x1713d000 eax = 0x679b82e8 ecx = 0x5a5a5a5a
02:43:14 INFO - edx = 0x00000000 efl = 0x00010206
02:43:14 INFO - Found by: given as instruction pointer in context
02:43:14 INFO - 1 xul.dll!mozilla::MediaFormatReader::VideoIsHardwareAccelerated() [MediaFormatReader.cpp:b46f7d0b2c4b : 1325 + 0xe]
02:43:14 INFO - eip = 0x66a0924e esp = 0x0883fc14 ebp = 0x0883fc34
02:43:14 INFO - Found by: call frame info
02:43:14 INFO - 2 xul.dll!mozilla::MediaDecoderStateMachine::GetAmpleVideoFrames() [MediaDecoderStateMachine.cpp:b46f7d0b2c4b : 3464 + 0x1f]
02:43:14 INFO - eip = 0x669f1da5 esp = 0x0883fc18 ebp = 0x0883fc34
02:43:14 INFO - Found by: call frame info
02:43:14 INFO - 3 xul.dll!mozilla::MediaDecoderStateMachine::HaveEnoughDecodedVideo() [MediaDecoderStateMachine.cpp:b46f7d0b2c4b : 639 + 0x2a]
02:43:14 INFO - eip = 0x669f48c4 esp = 0x0883fc20 ebp = 0x0883fc34
02:43:14 INFO - Found by: call frame info
02:43:14 INFO - 4 xul.dll!mozilla::MediaDecoderStateMachine::NeedToDecodeVideo() [MediaDecoderStateMachine.cpp:b46f7d0b2c4b : 667 + 0x4d]
02:43:14 INFO - eip = 0x669f72bb esp = 0x0883fc3c ebp = 0x0883fc50
02:43:14 INFO - Found by: call frame info
02:43:14 INFO - 5 xul.dll!mozilla::MediaDecoderStateMachine::DispatchVideoDecodeTaskIfNeeded() [MediaDecoderStateMachine.cpp:b46f7d0b2c4b : 2009 + 0x6]
02:43:14 INFO - eip = 0x669eeb98 esp = 0x0883fc44 ebp = 0x0883fc50
02:43:14 INFO - Found by: call frame info
02:43:14 INFO - 6 xul.dll!nsRunnableMethodImpl<void ( mozilla::dom::ServiceWorkerRegistrar::*)(void),1>::Run() [nsThreadUtils.h:b46f7d0b2c4b : 825 + 0x2]
02:43:14 INFO - eip = 0x65c67913 esp = 0x0883fc50 ebp = 0x0883fc50
02:43:14 INFO - Found by: call frame info
02:43:14 INFO - 7 xul.dll!mozilla::AutoTaskDispatcher::TaskGroupRunnable::Run() [TaskDispatcher.h:b46f7d0b2c4b : 174 + 0x8]
02:43:14 INFO - eip = 0x669de93a esp = 0x0883fc58 ebp = 0x0883fc70
02:43:14 INFO - Found by: call frame info
02:43:14 INFO - 8 xul.dll!mozilla::MediaTaskQueue::Runner::Run() [MediaTaskQueue.cpp:b46f7d0b2c4b : 257 + 0x8]
02:43:14 INFO - eip = 0x66a13d4b esp = 0x0883fc78 ebp = 0x0883fcbc
02:43:14 INFO - Found by: call frame info
02:43:14 INFO - 9 xul.dll!nsThreadPool::Run() [nsThreadPool.cpp:b46f7d0b2c4b : 226 + 0x5]
02:43:14 INFO - eip = 0x65cc8666 esp = 0x0883fcc4 ebp = 0x0883fcec
02:43:14 INFO - Found by: call frame info
02:43:14 INFO - 10 xul.dll!nsThread::ProcessNextEvent(bool,bool *) [nsThread.cpp:b46f7d0b2c4b : 866 + 0x5]
02:43:14 INFO - eip = 0x65a292b7 esp = 0x0883fcf4 ebp = 0x0883fdf4
02:43:14 INFO - Found by: call frame info
02:43:14 INFO - 11 xul.dll!NS_ProcessNextEvent(nsIThread *,bool) [nsThreadUtils.cpp:b46f7d0b2c4b : 265 + 0xa]
02:43:14 INFO - eip = 0x65b20906 esp = 0x0883fdfc ebp = 0x0883fe10
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1166288
Keywords: crash, intermittent-failure
You need to log in before you can comment on or make changes to this bug.