Closed Bug 1167178 Opened 5 years ago Closed 3 years ago

The newtab option menu items are not correctly aligned in RTL builds

Categories

(Firefox :: New Tab Page, defect)

41 Branch
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 54
Tracking Status
firefox41 --- affected
firefox54 --- fixed

People

(Reporter: cornel_ionce, Assigned: tomer)

References

()

Details

(Whiteboard: [testday-20170512])

Attachments

(2 files)

Reproducing using latest Nightly, build ID: 20150520030205.

STR:
1. Open Firefox using a RTL locale;
2. Navigate to about:newtab;
3. Click on the cog wheel.

Results:
The new tab option menu item alignment is messed up.

Issue on the:
- He build: http://i.imgur.com/vyShObX.png
- Ar build: http://i.imgur.com/s9h4mrq.png

Also reproduced this using the en-US build by creating a intl.uidirection.en pref and set it's value to RTL.
Attached image Screenshot (he)
Issue is a bit better than the previously supplied screenshots, but is still not fully resolved. I'm planning to look into this issue.
Assignee: nobody → tomer.moz.bugs
Status: NEW → ASSIGNED
Attachment #8829213 - Flags: review?(msamuel) → review?(adw)
Comment on attachment 8829213 [details]
Bug 1167178 - The newtab option menu items are not correctly aligned in RTL builds

https://reviewboard.mozilla.org/r/106360/#review117800

Thanks very much! :-)
Attachment #8829213 - Flags: review?(adw) → review+
And sorry for the big delay.
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Sorry, accidentally marked as RESOLVED FIXED.
Pushed by ryanvm@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/34dcb179266b
The newtab option menu items are not correctly aligned in RTL builds r=adw
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/34dcb179266b
Status: REOPENED → RESOLVED
Closed: 3 years ago3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 54
Looking good on latest Nightly.
Great, thanks again Tomer.
Status: RESOLVED → VERIFIED
QA Whiteboard: [good first verify]
Reproduced the bug in firefox beta 39.0.3 (2015-08-06) with windows 10 (64 bit)

Verified as fixed with latest firefox beta 54.0b7 (Build ID: 20170511130324)

Mozilla/5.0 (Windows NT 10.0; WOW64; rv:54.0) Gecko/20100101 Firefox/54.0
Whiteboard: [testday-20170512]
You need to log in before you can comment on or make changes to this bug.