Closed Bug 1167188 Opened 5 years ago Closed 3 years ago

Add an option to display source map requests from tools in the netmonitor

Categories

(DevTools :: Netmonitor, defect, P3)

defect

Tracking

(firefox41 affected)

RESOLVED DUPLICATE of bug 1345533
Tracking Status
firefox41 --- affected

People

(Reporter: past, Unassigned)

References

(Blocks 1 open bug)

Details

Bug 1163024 made sure that only network requests from content appear in the network monitor. Inspecting network requests made by chrome code can be doe with the Browser Toolbox or Browser Console. Some users however may be used to look for failed source map requests in the content tools, so it seems like a good idea to provide an option for this set of users.

The best solution would be to mark related requests with a new sourcemap-specific policy and have the NetworkMonitor filter those based on a preference set by the user (like the existing NetworkMonitor.saveRequestAndResponseBodies).

Worst case we could add a pref that toggles the existing behavior for all requests, but the messaging should be sufficiently clear in that case.
Duplicate of this bug: 886233
Priority: -- → P3
It seems to me that a new policy would not be sufficient --
for example the devtools could be opened for multiple tabs at once, and each could be
fetching source maps separately.  Maybe one alternate approach would be to have something
like DevToolsUtils.js:fetch register the new channel with the network monitor code.
We're taking a different approach to notifying the user of sourcemap failures in bug 1345533.
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1345533
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.