Sync doorhanger from add-on install process is no longer displayed for another add-on once it has been closed

RESOLVED INVALID

Status

()

Toolkit
Add-ons Manager
RESOLVED INVALID
2 years ago
2 years ago

People

(Reporter: Vasilica Mihasca, QA [away for an extended period of time - please needinfo addonsqa@softvision.ro], Assigned: mossop)

Tracking

Trunk
Points:
---
Bug Flags:
firefox-backlog +

Firefox Tracking Flags

(firefox41 affected)

Details

(Whiteboard: [fxsearch][hijacking])

Reproducible on: Firefox 41.0a1 and Firefox 40.0a2 across all platforms 

Prerequisites: create xpinstall.signatures.dev-root pref and set it to true

1.Launch Firefox with clean profile
2.Go to https://addons-dev.allizom.org/en-US/firefox/addon/video-downloadhelper/?src=cb-dl-users
3.Click ”Add to Firefox” green button
4.Click “Allow” button
5.After the add-on is downloaded and verified, click “Install” button
6.In the last doorhanger click “x” button which corresponds to sync section in order to close this box. ( http://i.imgur.com/diNWY6n.jpg )
7.Repeat steps 3,4 and 5 for another add-on installation ( e.g https://addons-dev.allizom.org/en-US/firefox/addon/firebug/?src=cb-dl-users )
8.Check the Sync section from the last add-on confirmation doorhanger ( http://i.imgur.com/MDeXsMc.jpg )


ER
Sync doorhanger appears for each add-on install process.

AR
Sync doorhanger is no longer displayed for any install process once it has been closed.


Additional notes:
- This issue is reproducible on Firefox 41.0a1 (2015-05-20) and 40.0a2 (2015-05-20) using Windows 7 64-bit, Ubuntu 14.04 64-bit and Mac OS X 10.9.5.
(Assignee)

Comment 1

2 years ago
Looks like probably fallout from bug 1162584
Assignee: nobody → dtownsend
Blocks: 1162584
Flags: firefox-backlog+
Keywords: regression
Whiteboard: [fxsearch][hijacking]
(Assignee)

Comment 2

2 years ago
Sorry misread this. If you click the symc promo close button then it's not meant to show up again, see bug 618913 comment 7.
No longer blocks: 1162584
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Keywords: regression
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.