websockets Assertion failure: index >= 0 (connection to remove not in queue)

RESOLVED DUPLICATE of bug 1170645

Status

()

Core
Networking: WebSockets
RESOLVED DUPLICATE of bug 1170645
3 years ago
2 years ago

People

(Reporter: bc, Assigned: michal)

Tracking

(Blocks: 1 bug, {assertion})

Trunk
assertion
Points:
---

Firefox Tracking Flags

(firefox41 affected)

Details

(Whiteboard: [necko-active], crash signature, URL)

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8608729 [details]
Crash report

1. https://ru.4game.com/
2. Assertion failure: index >= 0 (connection to remove not in queue), at /mozilla/builds/nightly/mozilla/netwerk/protocol/websocket/WebSocketChannel.cpp:507

[@ mozilla::net::nsWSAdmissionManager::RemoveFromQueue(mozilla::net::WebSocketChannel*) ]

Nightly/41 OSX, Linux, Windows
I hit this pretty often in my daily browsing (I suspect github); any chance you could have a look?
Flags: needinfo?(michal.novotny)
(Assignee)

Comment 2

2 years ago
Could you please send me the backtrace of the assert? The crash reported by Bob was fixed in bug 1170645 and the patch was uplifted to aurora 40.
Flags: needinfo?(michal.novotny)

Updated

2 years ago
Crash Signature: [@ mozilla::net::nsWSAdmissionManager::RemoveFromQueue(mozilla::net::WebSocketChannel*) ] → [@ mozilla::net::nsWSAdmissionManager::RemoveFromQueue(mozilla::net::WebSocketChannel*) ] [@ mozilla::net::nsWSAdmissionManager::RemoveFromQueue ]
this was in comment 0

Operating system: Mac OS X
                  10.6.8 10K549
CPU: amd64
     family 6 model 23 stepping 10
     2 CPUs

Crash reason:  EXC_BAD_ACCESS / KERN_INVALID_ADDRESS
Crash address: 0x0
Process uptime: 34 seconds

Thread 0 (crashed)
 0  XUL!mozilla::net::nsWSAdmissionManager::RemoveFromQueue(mozilla::net::WebSocketChannel*) [WebSocketChannel.cpp : 507 + 0x0]
    rax = 0x0000000000000000   rdx = 0x0000000000000000
    rcx = 0x0000000000000001   rbx = 0x000000010051b420
    rsi = 0x0000000000000000   rdi = 0x00007fff71072a60
    rbp = 0x00007fff5fbf7850   rsp = 0x00007fff5fbf7810
     r8 = 0x00007fff71072a60    r9 = 0x0000000000000001
    r10 = 0x0000000001000000   r11 = 0x00007fff5fbf6cb0
    r12 = 0x000000010051b434   r13 = 0x0000000000000001
    r14 = 0x0000000100103d10   r15 = 0x0000000100103d10
    rip = 0x00000001023c01b6
    Found by: given as instruction pointer in context
 1  XUL!mozilla::net::nsWSAdmissionManager::OnStopSession(mozilla::net::WebSocketChannel*, nsresult) [WebSocketChannel.cpp : 429 + 0x10]
    rbp = 0x00007fff5fbf78b0   rsp = 0x00007fff5fbf7860
    rip = 0x00000001023b95a7
    Found by: previous frame's frame pointer
 2  XUL!mozilla::net::CallOnStop::Run() [WebSocketChannel.cpp : 617 + 0x21]
    rbp = 0x00007fff5fbf78f0   rsp = 0x00007fff5fbf78c0
    rip = 0x00000001023bae19
    Found by: previous frame's frame pointer
 3  XUL!nsThread::ProcessNextEvent(bool, bool*) [nsThread.cpp : 866 + 0x1c]
    rbp = 0x00007fff5fbf7ae0   rsp = 0x00007fff5fbf7900
    rip = 0x0000000101f17f36
    Found by: previous frame's frame pointer
 4  XUL!NS_ProcessPendingEvents(nsIThread*, unsigned int) [nsThreadUtils.cpp : 207 + 0xd]
    rbp = 0x00007fff5fbf7b20   rsp = 0x00007fff5fbf7af0
    rip = 0x0000000101f72f1b
    Found by: previous frame's frame pointer
 5  XUL!nsBaseAppShell::NativeEventCallback() [nsBaseAppShell.cpp : 99 + 0x18]
    rbp = 0x00007fff5fbf7b60   rsp = 0x00007fff5fbf7b30
    rip = 0x000000010576c009
    Found by: previous frame's frame pointer
 6  XUL!nsAppShell::ProcessGeckoEvents(void*) [nsAppShell.mm : 377 + 0x9]
    rbp = 0x00007fff5fbf7ca0   rsp = 0x00007fff5fbf7b70
    rip = 0x00000001057ea711
    Found by: previous frame's frame pointer
Assignee: nobody → michal.novotny
Flags: needinfo?(michal.novotny)
Summary: Assertion failure: index >= 0 (connection to remove not in queue) → websockets Assertion failure: index >= 0 (connection to remove not in queue)
Whiteboard: [necko-active]
(Assignee)

Comment 4

2 years ago
(In reply to Patrick McManus [:mcmanus] from comment #3)
> this was in comment 0

But that report is from 2015-05-21 and the fix in bug 1170645 has landed on 2015-06-22. So if Ms2ger hit this assertion after the fix has landed I need the backtrace. Closing as dupe for now, please reopen if you see the problem again.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(michal.novotny)
Resolution: --- → DUPLICATE
Duplicate of bug: 1170645
You need to log in before you can comment on or make changes to this bug.