Disable/set expiry for celery event queues

RESOLVED DUPLICATE of bug 1215102

Status

P2
normal
RESOLVED DUPLICATE of bug 1215102
3 years ago
3 years ago

People

(Reporter: emorley, Unassigned)

Tracking

Details

(Reporter)

Description

3 years ago
We're apparently not using the event queues, so we should switch them off to reduce the noise due to bug .

I think we'll want to use some combination of:
CELERY_SEND_EVENTS
CELERY_EVENT_QUEUE_TTL
CELERY_EVENT_QUEUE_EXPIRES

...as well as stopping using the "-E" parameter on the command line (which strangely we only use for some of the workers):

https://github.com/mozilla/treeherder/blob/9da6ddbf4151436f20a763d9543b86409214d8c3/bin/run_celery_worker#L27
https://github.com/mozilla/treeherder/blob/9da6ddbf4151436f20a763d9543b86409214d8c3/bin/run_celery_worker_hp#L26
(Reporter)

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1215102
You need to log in before you can comment on or make changes to this bug.