background image not properly drawn

RESOLVED DUPLICATE of bug 115046

Status

()

Core
Layout: HTML Frames
RESOLVED DUPLICATE of bug 115046
16 years ago
16 years ago

People

(Reporter: René Rhéaume, Assigned: John Keiser (jkeiser))

Tracking

({regression, testcase})

Trunk
mozilla1.1alpha
x86
Windows 98
regression, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 obsolete attachments)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows 98)
BuildID:    2001122106

The background image of the upper frame (a text menu) is painted only below the 
table and not to all the width of the page if I hover a link.

I open that page in a separate tab and the problem does not occur.

This problem occur in mozilla 0.9.7, but not in Mozilla 0.9.3 through 0.9.6.

Reproducible: Sometimes
Steps to Reproduce:
1.Open the frame page (accueil_ie4.html)
2.Hover a link of the upper frame

Actual Results:  The background is only drawn below the table.

Expected Results:  The backgound image should be all across the width of the 
frame

I put all the pages of the frame system :

[menu.htm] (page that has the problem)
<html>

<head>
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">
<meta name="GENERATOR" content="Microsoft FrontPage 4.0">
<meta name="ProgId" content="FrontPage.Editor.Document">
<title>Menu du haut</title>
<base target="Contenu">
<style type="text/css">
<!--
body         { background-color: #7A99C9; color: #000000; background-image: 
               url('images/BackMenuHaut.gif'); background-repeat: repeat-x; 
               font-family: Verdana, Arial, sans-serif; font-weight: 400; font-
size: 11px; 
               border: 1px outset #608FBF; margin: 0px; background-position: 
50% 0% }
td           { font-size: 11px; font-family: Verdana, Arial, sans-serif; font-
weight: 400;
               text-align: center; vertical-align: middle;
               color: #000000; background-color: transparent; padding: 1px; 
margin: 0px; }
a            { font-weight: 400; text-decoration: none; 
               color: #000000; background-color: transparent; }
a:hover      { font-weight: 400; color: #000000; background-color: #D0E0F0; 
               border: .14em outset #90B0EF; }
a:focus      { font-weight: 400; color: #000000; background-color: #D0E0F0; 
               border: .14em outset #90B0EF; }
a:active     { font-weight: 400; color: #9F9F9F; background-color: #D0E0F0; 
               border: 1px inset #90B0EF; }
-->
</style>
</head>

<body>

<table border="0" style="height: 21px">
  <tr>
    <td width="57"><a href="cadre-bas_accueil_ie4.htm">Accueil</a></td>
    <td width="75"><a href="produits/cadre-
bas_produits_ie4.htm">Produits</a></td>
    <td width="86"><a href="commander/cadre-
bas_commander_ie4.htm">Commander</a></td>
    <td width="104"><a href="organigramme/cadre-
bas_organigramme_ie4.htm">Organigramme</a></td>
    <td width="82"><a href="rapports/cadre-
bas_rapports_ie4.htm">Rapports</a></td>
    <td width="20"><EMBED SRC="UTMenu23-40.wma" width="1" height="1" border="0" 
hidden="true"></EMBED></td>
  </tr>
</table>
</body>

</html>


[accueil_ie4.html] (main frame definition file)
<html>

<head>
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">
<title>La Messagerie des Fêtes inc.</title>
<meta name="GENERATOR" content="Microsoft FrontPage 4.0">
<meta name="ProgId" content="FrontPage.Editor.Document">
</head>

<frameset framespacing="0" border="0" frameborder="0" rows="23,*">
  <frame name="Menu" scrolling="no" noresize src="menu.htm" marginwidth="0" 
marginheight="0">
  <frame name="Contenu" src="cadre-bas_accueil_ie4.htm" scrolling="auto" 
noresize marginwidth="0" marginheight="0">
  <noframes>
  <body>

  <p><font face="Verdana, Arial" size="2">Cette site utilise des cadres, mais
  votre navigateur est trop ancien pour les supporter.</font></p>
  <ul type="DISC">
    <li><font face="Verdana, Arial" size="2"><a 
href="http://www.microsoft.com/windows/ie_intl/fr" title="Télécharger 
Internet Explorer">Internet
      Explorer</a></font></li>
    <li><font face="Verdana, Arial" size="2"><a 
href="http://home.netscape.com/fr/download/index.html" title="Télécharger 
Netscape Navigator">Netscape
      Navigator</a></font></li>
  </ul>

  </body>
  </noframes>
</frameset>

</html>


[cadre-bas_accueil_ie4.htm] (secondary frame definition file)
<html>

<head>
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">
<title>Page de cadres de contenu (accueil)</title>
<meta name="GENERATOR" content="Microsoft FrontPage 4.0">
<base target="principal">
</head>

<frameset framespacing="0" border="0" frameborder="0" cols="160,*">
  <frame name="sommaire" target="principal" src="pann-gauche_accueil_ie4.htm" 
scrolling="auto" marginwidth="0" marginheight="0" noresize>
  <frame name="principal" src="contenu-accueil_ie4.htm">
  <noframes>
  <body>

  <p><font face="Verdana, Arial" size="2">Cette site utilise des cadres, mais
  votre navigateur est trop ancien pour les supporter.</font></p>
  <ul type="DISC">
    <li><font face="Verdana, Arial" size="2"><a 
href="http://www.microsoft.com/windows/ie_intl/fr" 
title="T&eacute;l&eacute;charger Internet Explorer">Internet
      Explorer</a></font></li>
    <li><font face="Verdana, Arial" size="2"><a 
href="http://home.netscape.com/fr/download/index.html" 
title="T&eacute;l&eacute;charger Netscape Navigator">Netscape
      Navigator</a></font></li>
  </ul>

  </body>
  </noframes>
</frameset>

</html>


[pann-gauche_accueil_ie4.htm] (side frame contents)
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 
Transitional//EN" "http://www.w3.org/TR/1999/REC-html401-19991224/loose.dtd">
<html>

<head>
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">
<meta name="GENERATOR" content="Microsoft FrontPage 4.0">
<title>Panneau de gauche (accueil)</title>
<base target="principal">
<link rel="stylesheet" type="text/css" href="pann-gauche.css">
</head>

<body>

<!--<h3>La Messagerie des Fêtes inc.</h3>-->
<p>
<SCRIPT LANGUAGE="JavaScript">
<!-- Debut script
var entPosChaineMSIE = navigator.userAgent.indexOf("MSIE")
var entVersionNavigateur = navigator.appVersion.substring(0,1)

if (entPosChaineMSIE != -1) {
	document.write('<img src="images/logoweb.gif" name="Logo" alt="La 
Messagerie des F&ecirc;tes inc. - Logo" width="145" height="246">');
	}
// Netscape ou Mozilla est détecté
else {
	if (entVersionNavigateur >= 5) {
		document.write('<img src="images/logoweb.png" name="Logo" 
alt="La Messagerie des F&ecirc;tes inc. - Logo" width="145" height="246">');
	}
	else {
		document.write('<img src="images/logoweb.gif" name="Logo" 
alt="La Messagerie des F&ecirc;tes inc. - Logo" width="145" height="246">');
	}
}
//  Fin script -->
</SCRIPT>
<NOSCRIPT>
<img src="images/logoweb.gif" name="Logo" alt="La Messagerie des F&ecirc;tes 
inc. - Logo" width="145" height="246">
</NOSCRIPT></p>
<p>Cliquez sur un des liens du menu du haut pour naviguer &agrave; travers le 
site. Un
sous-menu s'affichera ici.</p>

</body>

</html>


[contenu-accueil_ie4.htm] ("real" content page) (shortened)
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 
Transitional//EN" "http://www.w3.org/TR/1999/REC-html401-19991224/loose.dtd">
<html>

<head>
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">
<meta name="GENERATOR" content="Microsoft FrontPage 4.0">
<meta name="ProgId" content="FrontPage.Editor.Document">
<title>La Messagerie des Fêtes inc. - Accueil</title>
<link rel="stylesheet" type="text/css" href="contenu.css">
</head>

<body>

<table border="0" width="80%">
  <tr>
    <td class="tblblanc">
      <h1>La Messagerie des Fêtes inc. - Bienvenue</h1>
    </td>
  </tr>
</table>

</body>

</html>

I can can send you the background image by email. It is < 1 Kb.

Comment 1

16 years ago
Do you have an URL where I can see this problem?
(Reporter)

Comment 2

16 years ago
I have one now :

http://www.mediom.com/~rener/messageriefetes/accueil_ie4.html

Don't bother with the _ie4 suffix. It's just a reference for me that this page 
uses CSS (and was much more better in IE4 than in NS4).
(Reporter)

Comment 3

16 years ago
I tried on my system to tweak the "menu bar" page (menu.htm) and the bug I
reported happens in both standard and quirk modes. The page
http://www.mediom.com/~rener/messageriefetes/menu.htm is rendered in quirk mode,
FYI.

Unfortunaltely, the page is uglier in standard mode. There is an undesirable
margin above the links and CSS attribute "margin: 0px;" does not work.

Comment 4

16 years ago
Confirming issue in the Jan 3rd build (2002-01-03-08). Reduced test case in process
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 5

16 years ago
Created attachment 63458 [details]
Modified frameset test case to load menu and mozilla in frameset

Download this frameset html test case to local machine.

Comment 6

16 years ago
Created attachment 63459 [details]
Reduced menu test case

Simple table with the two css rules applied:

body	     { background-color: #7A99C9; color: #000000;}
	    
a:hover      { color: #ffffff; background-color: red; 
	       border: .14em ; }

Comment 7

16 years ago
Save both attached test case to local drive. Load frameset.htm file in browser.
The frameset contains two frames row (first row has scrolling disabled). If you
mouse over the text "Accueil" in the first frame, notice the background drops
out of frame. This is a frameset issue since it's can be resolved by changing
the scrolling value (in the first frame) to "auto".
(Reporter)

Comment 8

16 years ago
Confirmed bug reproduction with reduced test case with Mozilla 0.9.7 milestone.

Updated

16 years ago
Keywords: testcase

Comment 9

16 years ago
Changing component to HTML frames
Component: Layout → HTMLFrames

Updated

16 years ago
Keywords: regression
Target Milestone: --- → mozilla1.1
*** Bug 122040 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 11

16 years ago
How can I query mozilla.org web tools to get the changes done to HTMLFrames
between 0.9.6 and 0.9.7 ?
->default owner
Assignee: attinasi → jkeiser
QA Contact: petersen → amar
(Assignee)

Comment 13

16 years ago
Created attachment 77984 [details]
Live Testcase

This testcase can be used directly from Bugzilla.
Attachment #63458 - Attachment is obsolete: true
Attachment #63459 - Attachment is obsolete: true
(Assignee)

Comment 14

16 years ago

*** This bug has been marked as a duplicate of 115046 ***
No longer blocks: 131673
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
(Assignee)

Updated

16 years ago
Attachment #77984 - Attachment mime type: application/octet-stream → text/html
(Assignee)

Comment 15

16 years ago
Comment on attachment 77984 [details]
Live Testcase

OK, I uploaded the wrong file and the right one is gone from my hard drive.  I
have verified that the given testcase works in the given bug, though.
Attachment #77984 - Attachment is obsolete: true
You need to log in before you can comment on or make changes to this bug.