Do not store tab state at startup

RESOLVED DUPLICATE of bug 1164160

Status

()

RESOLVED DUPLICATE of bug 1164160
3 years ago
3 years ago

People

(Reporter: st3fan, Assigned: st3fan)

Tracking

unspecified
Other
iOS

Firefox Tracking Flags

(fennec+)

Details

(Assignee)

Description

3 years ago
Related to bug 1167288 which happened because we were storing the tab state while we were recreating new tabs at startup.

In that bug it is suggested that we wait to do that until all tabs have loaded. But that is not a good idea because I think ideally we want tabs to be loaded lazily anyway.

I think we should simply not store tab state at all during tab re-creation at startup. I doubt that makes sense because the tabs we are restoring should be stored already.
Depends on: 1167288
(Assignee)

Comment 1

3 years ago
Can this be as simple as removing storeChanges() from TabManager.decodeRestorableStateWithCoder? That method already calls self.addTab(request: NSURLRequest(URL: url), flushToDisk: false) with flushToDisk set to false. So not sure why we are undoing that at the end of the call.
Assignee: nobody → sarentz
tracking-fennec: ? → +
Note, I don't even this we're storing these anymore. i.e. Storage seems nil when we create the TabManager.
(Assignee)

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1164160
You need to log in before you can comment on or make changes to this bug.