Remove Amazon and IMDb from shumway.swf.whitelist pref

RESOLVED FIXED in Firefox 41

Status

defect
RESOLVED FIXED
4 years ago
3 years ago

People

(Reporter: cpeterson, Assigned: cpeterson)

Tracking

Trunk
Firefox 41
Dependency tree / graph

Firefox Tracking Flags

(firefox41 fixed)

Details

Attachments

(1 attachment)

(Assignee)

Description

4 years ago
Amazon and IMDb videos are currently broken (bug 1150189 and bug 1164013). Tobias says IMDb is now using HLS video, repacking into MP4 in Flash. Amazon is probably doing something similar.

Since the Shumway team's current focus is Flash ads, not videos, we should just remove Amazon and IMDB from our shumway.swf.whitelist pref since this seems to be a content change, not a Shumway regression.

See bug 1137433 for the code where IMDb was added to the shumway.swf.whitelist pref.
Please notice that pref entry shall exist and be set to the non-empty value. I suggest "http://www.areweflashyet.com/*".
(Assignee)

Comment 2

4 years ago
Replace the Amazon/IMDb whitelist with the whitelist that Yury recommended in comment 1, but include a "*.swf" suffix because that is pattern format that was used for the Amazon/IMDb patterns. It's also Shumway's default whitelist for platforms that don't support platform video decoders:

https://github.com/mozilla/shumway/blob/a7de3ad334098582ddb630a85e088a10b29b56db/extension/firefox/content/ShumwayBootstrapUtils.jsm#L121
Assignee: bugs → cpeterson
Status: NEW → ASSIGNED
Attachment #8611032 - Flags: review?(till)
Comment on attachment 8611032 [details] [diff] [review]
shumway-whitelist-pref.patch

Review of attachment 8611032 [details] [diff] [review]:
-----------------------------------------------------------------

Excellent, thank you!

I filed bug 1168761 for removing some special-casing in our code.
Attachment #8611032 - Flags: review?(till) → review+
https://hg.mozilla.org/mozilla-central/rev/578160b452ec
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 41
(Assignee)

Updated

4 years ago
Duplicate of this bug: 1171641
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.