Closed Bug 1167346 Opened 5 years ago Closed 4 years ago

comm-aurora builds are not building due to DOMi and Chatzilla pulling from revisions earlier than bug 1158751 - Port NO_JS_MANIFEST changes

Categories

(SeaMonkey :: Build Config, defect, critical)

defect
Not set
critical

Tracking

(firefox41 affected)

RESOLVED FIXED
seamonkey2.38
Tracking Status
firefox41 --- affected

People

(Reporter: philip.chee, Assigned: philip.chee)

References

()

Details

User Story

DOM Inspector

1. Bump application max versions for DOMi 2.0.16
2. Bump DOMi version to 2.0.16
3. Added tag DOMI_2_0_16 for changeset a9f69279b0fb
4. Added tag SEA2_37_RELBRANCH for DOMI_2_0_16
5. Bump DOMi version to 2.0.17pre
6. Rebase due to sv-SE update.
7. Added tag DOMI_2_0_16 for changeset dfad1b2e38e4.
8. Added tag SEA2_37_RELBRANCH for DOMI_2_0_16
9. State of the repository: http://hg.mozilla.org/dom-inspector/graph/ef293179f8c2

Chatzilla

1. Added tag SEA2_37_RELBRANCH for changeset 64c11fe5c513.
2. State of the repository: http://hg.mozilla.org/chatzilla/graph/944639546086

Attachments

(5 files)

No description provided.
This patch - together with the DOMi and Chatzilla updated to the SEA2_37_RELBRANCH allows comm-aurora (SeaMonkey 2.37) to build properly
Assignee: nobody → philip.chee
Status: NEW → ASSIGNED
Attachment #8608942 - Flags: review?(iann_bugzilla)
User Story: (updated)
Attachment #8608942 - Flags: review?(iann_bugzilla) → review+
Target Milestone: --- → seamonkey2.38
We need this on the current comm-aurora as well  (which was trunk when http://hg.mozilla.org/releases/comm-aurora/rev/ec75aab4aa5c was pushed).
this patch fixes the current comm-aurora.
Attachment #8630308 - Flags: review?(philip.chee)
Comment on attachment 8630308 [details] [diff] [review]
proposed patch (v1)

r=me thanks.
Attachment #8630308 - Flags: review?(philip.chee) → review+
Comment on attachment 8630308 [details] [diff] [review]
proposed patch (v1)

[Approval Request Comment]
Regression caused by (bug #): 1167346
User impact if declined: aurora fails to build.
Testing completed (on m-c, etc.): 
Risk to taking this patch (and alternatives if risky):
String changes made by this patch: none
Attachment #8630308 - Flags: approval-comm-aurora?
Comment on attachment 8630308 [details] [diff] [review]
proposed patch (v1)

a=me for comm-aurora
Attachment #8630308 - Flags: approval-comm-aurora? → approval-comm-aurora+
[Approval Request Comment]
Regression caused by (bug #): 
User impact if declined:  aurora doesn't build
Testing completed (on m-c, etc.): 
Risk to taking this patch (and alternatives if risky):
String changes made by this patch: None

client.py also requires a change in Chatzilla's revision to SEA2_37_RELBRANCH.
Attachment #8630333 - Flags: review?(philip.chee)
Attachment #8630333 - Flags: approval-comm-aurora?
Comment on attachment 8630333 [details] [diff] [review]
chatzilla relbranch change for client.py needed as well (v1)

r=me Assuming that Chatzilla repo has a SEA2_37_RELBRANCH
Attachment #8630333 - Flags: review?(philip.chee) → review+
Comment on attachment 8630333 [details] [diff] [review]
chatzilla relbranch change for client.py needed as well (v1)

a=me for comm‑aurora
Attachment #8630333 - Flags: approval-comm-aurora? → approval-comm-aurora+
Comment on attachment 8630333 [details] [diff] [review]
chatzilla relbranch change for client.py needed as well (v1)

Push to comm-aurora:
https://hg.mozilla.org/releases/comm-aurora/rev/06dfab093ef2
We need to push both https://bugzilla.mozilla.org/attachment.cgi?id=8630308 and
https://bugzilla.mozilla.org/attachment.cgi?id=8630333

to comm-aurora again because during the recent merge, the c-c's client.py
file had the wrong revisions.  

So what needs to be done are:

1) push the aforementioned patches to comm-aurora.
2) push the commented change to comm-central
Attachment #8646145 - Flags: review?(philip.chee)
Comment on attachment 8646145 [details] [diff] [review]
commented comm-central patch

r=me a=me CLOSED TREE

(In reply to Edmund Wong (:ewong) from comment #13)
> We need to push both https://bugzilla.mozilla.org/attachment.cgi?id=8630308
> and
> https://bugzilla.mozilla.org/attachment.cgi?id=8630333
> 
> to comm-aurora again because during the recent merge, the c-c's client.py
> file had the wrong revisions.  
> 
> So what needs to be done are:
> 
> 1) push the aforementioned patches to comm-aurora.
> 2) push the commented change to comm-central

r=me a=me CLOSED TREE for the current comm-aurora as well
Attachment #8646145 - Flags: review?(philip.chee) → review+
Comment on attachment 8646145 [details] [diff] [review]
commented comm-central patch

Pushed to comm-central:
 https://hg.mozilla.org/comm-central/rev/b3aa1e800b4a 

(with NPOTB)
I'm going to combine the needed two patches to one patch.
Comment on attachment 8646179 [details] [diff] [review]
checkin patch for (11th Aug. 2015)'s c-a (2.39)

Pushed to comm-aurora:
https://hg.mozilla.org/releases/comm-aurora/rev/4c5cdd846354
I think we need another update in client.py for Chatzilla to SEA2_42_RELBRANCH
I just added some patch files for l10 to Bug 1210791. Its not my bug so I didn't set any review flags but nontheless I think Chatzilla branch in client.py should be adjusted for all branches to include the latest fixes. This would mean at least 2 new tags. One for current comm-release and one for c-b and c-a.
See Also: → 1258206
Lets close this bug. Anything remaining should go into new bugs to reduce confusion.
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.