Closed Bug 1167521 Opened 5 years ago Closed 5 years ago

Use the standard scroll view deceleration rate for faster vertical scrolling

Categories

(Firefox for iOS :: Browser, defect)

Other
iOS
defect
Not set
normal

Tracking

()

RESOLVED FIXED

People

(Reporter: ide, Assigned: ide)

Details

Attachments

(1 file)

47 bytes, text/x-github-pull-request
sleroux
: review+
Details | Review
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_10_3) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/43.0.2357.65 Safari/537.36

Steps to reproduce:

Scrolled a web page and upon lifting your finger from the screen to induce "momentum scrolling".


Actual results:

The page content coasts to a stop more quickly than a standard scroll view.


Expected results:

Expected the page content to coast at the standard deceleration rate. This is subjective so I'll make the argument for it.

Mobile-friendly sites are generally columns of vertical content. Making the web view scroll quickly improves the consumption experience since it helps users scroll through the feed of content with less friction. The standard deceleration rate also helps web pages feel like native app content and removes some of the perceived sluggishness.
Attached file Pull request
Attachment #8609234 - Flags: review?(sarentz)
Attachment #8609234 - Flags: review?(sarentz) → review?(sleroux)
Assignee: nobody → ide
Status: UNCONFIRMED → NEW
Ever confirmed: true
Attachment #8609234 - Flags: review?(sleroux) → review+
Merged
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.