If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Twitter Web App doesn't work on Firefox for Android

RESOLVED WONTFIX

Status

()

Firefox for Android
Web Apps
RESOLVED WONTFIX
2 years ago
2 years ago

People

(Reporter: João Portela, Unassigned)

Tracking

38 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_10_1) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/42.0.2311.152 Safari/537.36

Steps to reproduce:

Using Firefox for Android 38.0.1 from the Google Play. Cleaned all data before doing these steps and no addons are installed.

A1. Go the the Firefox Marketplace
A2. Select the Twitter web app
A3. Click on "Free" to install it

Then tried to download the apk and installing it via adb:
B1. Downloaded the apk manually doing 
curl -v -k https://controller-review.apk.firefox.com/application.apk\?manifestUrl\=https://mobile.twitter.com/cache/twitter.webapp -o twitter.apk
B2. Successfully downloaded it so installed it:
adb install twitter.apk
B3. Successfully installed it and opened it


Actual results:

A. Got an error installing the app and the following log on logcat
D/GeckoWebappManager(28389): error downloading APK: 504 - GATEWAY_TIMEOUTD/GeckoWebappManager(28389): error downloading APK: 504 - GATEWAY_TIMEOUT

B. When opening it I only got a blank screen (after getting the loading/splash screen with the Twitter logo)


Expected results:

A. Twitter web app is installed

B. Twitter web app opens the Twitter page.
(Reporter)

Comment 1

2 years ago
Also tried on Nightly and it does not work. I believe it is a problem somewhere in the Twitter code, as other web apps are working.
Per bug 1235869, we're going to disable the Android web runtime, so we won't fix this bug in it.

(This is part of a bulk resolution of bugs in the Firefox for Android::Web Apps component, from which I attempted to exclude bugs that are not specific to the runtime, but it's possible that I included one accidentally.  If so, I'm sorry, and please reopen the bug!)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.