registry installed extension not catch rdf file change

RESOLVED INVALID

Status

()

Toolkit
Add-ons Manager
RESOLVED INVALID
3 years ago
3 years ago

People

(Reporter: Max, Unassigned)

Tracking

38 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

265.16 KB, application/zip
Details
(Reporter)

Description

3 years ago
Created attachment 8609355 [details]
ffext.zip

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/42.0.2311.152 Safari/537.36 OPR/29.0.1795.60

Steps to reproduce:

I have registry installed extension as:
[HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Mozilla\Firefox\Extensions]
"my_ffext@my_ff_text.com"= "c:\Program Files (x86)\MyFFExtension"

Also my extension contains some .xpt files.

When I replace .rdf file by a new .rdf file with a new extension version and new supported browser version, sometimes FireFox doesn't see changes and doesn't refresh plug-in in add-ons list.

For ex:
I switch between 1.6.7/install.rdf and 1.6.8/install.rdf many times (see attachments).




Actual results:

Sometimes nothing happens.


Expected results:

Every time FF has to refresh my extension info.

Updated

3 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Component: Untriaged → Add-ons Manager
Product: Firefox → Toolkit
Resolution: --- → DUPLICATE
Duplicate of bug: 1165534
It would be too slow for Firefox to completely rescan every install.rdf file on startup so instead we check to see if the file's modification time has changed. If it hasn't we assume the contents haven't changed. Looking in the zip file provided all the file modification times for the install.rdf files are within a second of each other. This isn't enough to trigger a rescan (some filesystems have a time resolution of ~2 seconds).
Resolution: DUPLICATE → INVALID
You need to log in before you can comment on or make changes to this bug.