Closed Bug 1167641 Opened 7 years ago Closed 4 years ago

Flash fallback version of Vine videos embedded in twitter (Vine "/card" URLs) won't play (e.g. if you have pref media.mp4.enabled = false))

Categories

(Web Compatibility :: Desktop, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: dholbert, Unassigned, NeedInfo)

References

()

Details

(Whiteboard: [platform-rel-Twitter] [sitewait])

STR:
(1) In a linux Nightly build (*not* ubuntu's standard Firefox build), view this tweet:
   https://twitter.com/mistydemeo/status/601784844549500928

(2) Click through to the Vine page (via "view on web" or stylized "V" links)


ACTUAL RESULTS:
The embedded vine on Twitter (from step (1)) does not play; it just shows a still frame. The actual Vine page, however, does play.

EXPECTED RESULTS:
Video should play in step (1), on Twitter, like it does on Vine.


For comparison: If I use Ubuntu's provided Firefox version, or Chrome (both of which have built-in h.264 support and hence don't get the flash fallback), the video plays correctly.

[CC'ing Thomas, a Vine dev who helped out over on bug 1150957, in the hopes that he can take a look or perhaps know who to direct this to.]
Summary: Flash fallback version of Vine videos won't play on Twitter, when h.264 support is missing → Flash fallback version of Vine videos won't play on Twitter (in builds without h.264 support)
(Linux nightly builds available at http://nightly.mozilla.org/ btw)

My build info from about:support:
Build ID: 20150522030225
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:41.0) Gecko/20100101 Firefox/41.0
Flags: needinfo?(thomas)
Investigating!
Flags: needinfo?(thomas)
Confirmed issue, filed ticket internally.
Thanks!
* Ran 14.04 live CD
* Installed latest nightly
* Installed flash from apt
* Opened nightly, navigated to https://vine.co/v/MHBuLb71qMe/card
* Page attempts to load the flash shim, but fails & Firefox gives the "a webpage is causing Nightly to run slowly" bar

This is likely due to the fact that the latest version of Flash available for Firefox on Ubuntu is 11.2. Current for other platforms is 17. Adobe dropped support of Flash on Linux for all but Chrome[1].

Unfortunately, this is a WONTFIX for us.

1: http://blogs.adobe.com/flashplayer/2012/02/adobe-and-google-partnering-for-flash-player-on-linux.html
(In reply to Thomas R from comment #5)
> * Opened nightly, navigated to https://vine.co/v/MHBuLb71qMe/card
> * Page attempts to load the flash shim, but fails

That doesn't match what I'm seeing.

The Vine embedded in comment 0's tweet -- https://vine.co/v/eBOEiILuF75 -- plays just fine for me, using Flash, on Ubuntu 15.04 (locally). The only place I'm seeing trouble is vine-embedded-in-a-tweet.

> This is likely due to the fact that the latest version of Flash available
> for Firefox on Ubuntu is 11.2.

(I can confirm that about:plugins shows that I've got Flash 11.2.202.460. However, videos on Vine itself work just fine, so I don't think this is actually related.)

> Current for other platforms is 17. Adobe
> dropped support of Flash on Linux for all but Chrome[1].

True, but I haven't actually run across any serious breakage due to this yet, FWIW. (And as noted above, Vine itself seems to work fine for me; I'm only having trouble
(Sorry, didn't quite finish my previous comment:

(In reply to Daniel Holbert [:dholbert] from comment #6)
> (And as noted above, Vine itself seems to work fine for me; I'm
> only having trouble
...on vine-in-a-tweet).

I can confirm that https://vine.co/v/eBOEiILuF75/card does seem busted (though https://vine.co/v/eBOEiILuF75 is fine).  So this is something special about the "/card" view, I guess.

I'm skeptical that it's a flash bug, though, given that it works fine in the non-/card view.  Are you sure the flash fallback works at all (with up-to-date flash) on /card URIs?  (Seems like that might be hard to test, since the platforms/browsers that have up-to-date flash also have built-in h.264 support :).)
After some more poking, I did see a "causing nightly to run slowly" bar (as described in comment 5), and some occasional video-stopping-forever issues on the normally-working non-/card version of the dog video.

So, maybe flash isn't working as well as I thought, when it's working. :)  I'm still curious why /card specifically is always-broken while the non-/card view *mostly* works; but it looks like things maybe can't be perfect here even if /card pages matched non-/card pages playability-wise.

Anyway, thanks for taking a look!
Summary: Flash fallback version of Vine videos won't play on Twitter (in builds without h.264 support) → Flash fallback version of Vine videos embedded in twitter (Vine "/card" URLs) won't play (in builds without h.264 support)
Whiteboard: [platform-rel-Twitter]
platform-rel: --- → ?
Hi Daniel I'm triaging older Twitter related bugs. Is this one still valid?
Flags: needinfo?(dholbert)
Yes -- but these days, I need to toggle pref "media.mp4.enabled = false" in order to get the flash fallback (and then I can still reproduce the problem).

So the problem still exists, but maybe the space of users who receive flash fallback on this Vine site may have shrunk enough that this bug isn't super-high-priority.
Flags: needinfo?(dholbert)
Going to https://vine.co/v/eBOEiILuF75 with macosx (which has h.264). This is working obviously.

I'm not sure there's a solution Outreach has been done and vine replied on Comment #5 that it is a WONTFIX.
I wonder if Daniel has another suggestion or expectation?
Whiteboard: [platform-rel-Twitter] → [platform-rel-Twitter] [sitewait]
I think there was a misunderstanding in comment 5 -- see my response in comment 6 and comment 7.

(They seemed to be thinking that Flash was just completely failing because it was an old janky version. But as far as I can tell, Flash is working fine in at least some of their pages, and not at others; and it's unclear whether it's version-related because I don't think anyone here has tested flash fallback on non-linux.)

But anyway, there are few enough users who receive the flash fallback by default these days (given that we're shipping h.264 support on linux) that this isn't worth spending too much time on.
> it's unclear whether it's version-related because I don't think anyone here has tested flash fallback on non-linux

OK, update here -- I just verified this is *not* linux-specific, nor is it old-flash-specific. I can reproduce it on Mac OS El Capitan, with Firefox 48 and Flash 21.0.  To trigger the bug there, you simply need to disable h.264 support (so that you actually receive the flash fallback.

So we might want to punt this back to Vine, now that we have concrete STR with modern flash that don't require linux liveCD's or anything, which seems to have caused hassle/confusion in comment 5.  Thomas, if you're still around, perhaps you'd be up for taking another look, given this new information?

STEPS TO REPRODUCE ON ANY PLATFORM (using Firefox):
 1. Visit "about:config" and type in "mp4". Double-click "media.mp4.enabled" to disable mp4 support (set it to false)
   (This is just so you get the Flash fallback content.)

 2. Visit https://vine.co/v/eBOEiILuF75/card
     --> Notice that no video plays.
 3. Visit https://vine.co/v/eBOEiILuF75
     --> Notice that video *does* play there.

Therefore: Vine's "card" view (which is what gets embedded at Twitter) is broken, when hitting flash fallback.

I suspect/expect other browsers might hit the exact same bug, if you can disable mp4 support there.
Flags: needinfo?(thomas)
Summary: Flash fallback version of Vine videos embedded in twitter (Vine "/card" URLs) won't play (in builds without h.264 support) → Flash fallback version of Vine videos embedded in twitter (Vine "/card" URLs) won't play (though you'll only receive it if you have pref media.mp4.enabled = false))
Summary: Flash fallback version of Vine videos embedded in twitter (Vine "/card" URLs) won't play (though you'll only receive it if you have pref media.mp4.enabled = false)) → Flash fallback version of Vine videos embedded in twitter (Vine "/card" URLs) won't play (e.g. if you have pref media.mp4.enabled = false))
platform-rel: ? → ---
I think we can close this as WONTFIX, since vine is in maintenance/graveyard mode now. RIP vine, we didn't deserve you. :(
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WONTFIX
Product: Tech Evangelism → Web Compatibility
You need to log in before you can comment on or make changes to this bug.