[Keyboard][SIM PIN] SIM pin keyboard lingers after the SIM pin prompt is closed, or hidden

VERIFIED FIXED

Status

Firefox OS
Gaia::Keyboard
VERIFIED FIXED
2 years ago
2 years ago

People

(Reporter: DerekH, Assigned: timdream)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(blocking-b2g:2.5?, b2g-v2.2 unaffected, b2g-master verified)

Details

(Whiteboard: [3.0-Daily-Testing], URL)

Attachments

(3 attachments)

Created attachment 8609496 [details]
SIM pin Keyboard

Description:
The number pad keyboard that is shown on the screen when the user is asked to unlock their SIM on the SIM pin prompt page will take a long time to hide. This issue will occur if the user enters in their SIM pin, or if the user simply skips the SIM pin prompt page

Prerequisite: Have SIM pin enabled

Repro Steps:
1) Update a Flame to 20150522010227
2) Restart device, or toggle airplane mode on and off
3) Enter SIM pin, or skip SIM pin prompt


Actual:
The Numpad keyboard stays on screen for about 1 second after the prompt is gone 


Expected:
Numpad keyboard dismisses at the same time as the SIM pin prompt 


Environmental Variables:
Device: Flame 3.0 (319mb)(Kitkat)(Full Flash)
Build ID: 20150522010227
Gaia: 1126d8bee559f7cde675df2fcc6c196da9cfeba1
Gecko: 3e737d30f842
Gonk: 040bb1e9ac8a5b6dd756fdd696aa37a8868b5c67
Version: 41.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:41.0) Gecko/41.0 Firefox/41.0


Repro frequency: 10/10
See attached: Logcat, Video - https://youtu.be/r50DBlKmm4E
This issue does NOT occur on Flame 2.2

Numpad keyboard begins its transition off screen as soon as the SIM pin prompt dissappears

Environmental Variables:
Device: Flame 2.2 (319mb)(Kitkat)(Full Flash)
Build ID: 20150521002508
Gaia: bc42fbc12d622bffd7e8afcb8d56f8a1d9773c60
Gecko: 6e4eaf59efda
Gonk: bd9cb3af2a0354577a6903917bc826489050b40d
Version: 37.0 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
[Blocking Requested - why for this release]:
Noticeable regression.

Requesting a window.
blocking-b2g: --- → 3.0?
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
Keywords: regressionwindow-wanted

Updated

2 years ago
QA Contact: jthomas

Comment 3

2 years ago
Central Regression Window:

Last Working 
Environmental Variables:
Device: Flame 3.0
BuildID: 20150520181737
Gaia: b290c77ccb7ab0af599b3d8287b71b9970d8dcb0
Gecko: bc3500c5afa0
Version: 41.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:41.0) Gecko/41.0 Firefox/41.0


First Broken 
Environmental Variables:
Device: Flame 3.0
BuildID: 20150520182538
Gaia: 5a7f87b1505ba89b586372cbbbe9507d1016c40c
Gecko: b9424d63fe35
Version: 41.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:41.0) Gecko/41.0 Firefox/41.0


Last Working gaia / First Broken gecko - This issue does NOT with working Gaia.
Gaia: b290c77ccb7ab0af599b3d8287b71b9970d8dcb0
Gecko: b9424d63fe35

First Broken gaia / Last Working gecko - This issue DOES occur with broken Gaia. 
Gaia: 5a7f87b1505ba89b586372cbbbe9507d1016c40c
Gecko: bc3500c5afa0


Gaia Pushlog: 
https://github.com/mozilla-b2g/gaia/compare/b290c77ccb7ab0af599b3d8287b71b9970d8dcb0...5a7f87b1505ba89b586372cbbbe9507d1016c40c

==================================================

B2G Inbound Regression Window

Last Working 
Environmental Variables:
Device: Flame 3.0
BuildID: 20150520035741
Gaia: d910608af507188e612dc55ee730ef9233c0e777
Gecko: fc1b9ceab6be
Version: 41.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:41.0) Gecko/41.0 Firefox/41.0


First Broken 
Environmental Variables
BuildID: 20150520064142
Gaia: b830fde437465bc80fe960b1fd8b038d30ddcdc8
Gecko: 1a857bf3997e
Version: 41.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:41.0) Gecko/41.0 Firefox/41.0


Last Working gaia / First Broken gecko - This issue DOES occur with broken Gaia.
Gaia: d910608af507188e612dc55ee730ef9233c0e777
Gecko: 1a857bf3997e

First Broken gaia / Last Working gecko - This issue does NOT occur with working Gaia.
Gaia: b830fde437465bc80fe960b1fd8b038d30ddcdc8
Gecko: fc1b9ceab6be

Mozilla Inbound Pushlog:
https://github.com/mozilla-b2g/gaia/compare/d910608af507188e612dc55ee730ef9233c0e777...b830fde437465bc80fe960b1fd8b038d30ddcdc8

Issue appears to occur due to changes made in Bug 1162383.
Blocks: 1162383
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: regressionwindow-wanted
Timothy, can you take a look at this please? This might have been caused by the landing for bug 1162383.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker) → needinfo?(timdream)
Thanks for catching the issue.
Assignee: nobody → timdream
Status: NEW → ASSIGNED
Flags: needinfo?(timdream)

Comment 6

2 years ago
Created attachment 8613428 [details] [review]
[gaia] timdream:resize-compare > mozilla-b2g:master
Comment on attachment 8613428 [details] [review]
[gaia] timdream:resize-compare > mozilla-b2g:master

This cause of this bug is because the appWindow under the SIM dialog does not early return when it didn't actually resize.

The original compare expression is defective. It evaluates ("123.334px" === "123.3333333333333335px") to false. I don't know how many decimal places CSS spec is requiring the engine to cast the pixel value to (or it is spec'd at all), so this patch is a lazy solution which simply compares the integer part of the two numbers.
Attachment #8613428 - Flags: review?(alive)
Attachment #8613428 - Flags: review?(alive) → review+
Keywords: checkin-needed

Updated

2 years ago
Keywords: checkin-needed

Comment 8

2 years ago
http://docs.taskcluster.net/tools/task-graph-inspector/#mhITi_DpSdGkv3XfzX8OnA

The pull request failed to pass integration tests. It could not be landed, please try again.
Let's try again?
Keywords: checkin-needed

Updated

2 years ago
Keywords: checkin-needed

Comment 10

2 years ago
http://docs.taskcluster.net/tools/task-graph-inspector/#YI3BxHonQJ--4QYq0KETyA

The pull request failed to pass integration tests. It could not be landed, please try again.
Keywords: checkin-needed

Updated

2 years ago
Keywords: checkin-needed

Comment 11

2 years ago
http://docs.taskcluster.net/tools/task-graph-inspector/#uQNT_cuKScS71Ye1DY8UHA

The pull request failed to pass integration tests. It could not be landed, please try again.
Looks like I've missed the e-mail on autolander breakage.

master: https://github.com/mozilla-b2g/gaia/commit/d174a99493bd6d9cd197cb04874628ee7af9edc2
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
This bug has been verified as pass on latest Nightly build of Flame v3.0 and Nexus 5 v3.0 by the STR in Comment 0.

Actual results: When SIM PIN dialog closes/hides, the keyboard will dismiss simultaneously with no delay.
See attachment: verified_v3.0.mp4
Reproduce rate: 0/6


Device: Flame v3.0 build(Pass)
Build ID               20150603160203
Gaia Revision          45dc6306cf502a4f00ae9f8bd8293a8a3a37c07b
Gaia Date              2015-06-03 17:32:50
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/0920f2325a6d
Gecko Version          41.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150603.192042
Firmware Date          Wed Jun  3 19:20:53 EDT 2015
Bootloader             L1TC000118D0

Device: Nexus 5 v3.0 build(Pass)
Build ID               20150603160203
Gaia Revision          45dc6306cf502a4f00ae9f8bd8293a8a3a37c07b
Gaia Date              2015-06-03 17:32:50
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/0920f2325a6d
Gecko Version          41.0a1
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150603.193140
Firmware Date          Wed Jun  3 19:31:59 EDT 2015
Bootloader             HHZ12f
Status: RESOLVED → VERIFIED
status-b2g-master: affected → verified
Created attachment 8615194 [details]
verified_v3.0.mp4
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][MGSEI-Triage+]
You need to log in before you can comment on or make changes to this bug.