Closed Bug 1167655 Opened 7 years ago Closed 7 years ago

Handler function NM_observeActivity threw an exception: ReferenceError: gDevTools is not defined

Categories

(DevTools :: Netmonitor, defect)

defect
Not set
normal

Tracking

(firefox41 fixed)

RESOLVED FIXED
Firefox 41
Tracking Status
firefox41 --- fixed

People

(Reporter: tromey, Assigned: past)

Details

Attachments

(1 file)

I'm using fx-team from today.  I ran:

./mach test browser/devtools/performance/test/browser_markers-*.js

In the output I saw:

Handler function NM_observeActivity threw an exception: ReferenceError: gDevTools is not defined
Stack: NM__matchRequest@resource://gre/modules/commonjs/toolkit/loader.js -> resource://gre/modules/devtools/toolkit/webconsole/network-monitor.js:743:9
NM__onRequestHeader@resource://gre/modules/commonjs/toolkit/loader.js -> resource://gre/modules/devtools/toolkit/webconsole/network-monitor.js:880:10
NM_observeActivity@resource://gre/modules/commonjs/toolkit/loader.js -> resource://gre/modules/devtools/toolkit/webconsole/network-monitor.js:673:7
makeInfallible/<@resource://gre/modules/commonjs/toolkit/loader.js -> resource://gre/modules/devtools/DevToolsUtils.js:82:14
Line: 743, column: 8
Handler function NM__httpResponseExaminer threw an exception: ReferenceError: gDevTools is not defined
Stack: NM__matchRequest@resource://gre/modules/commonjs/toolkit/loader.js -> resource://gre/modules/devtools/toolkit/webconsole/network-monitor.js:743:9
NM__httpResponseExaminer@resource://gre/modules/commonjs/toolkit/loader.js -> resource://gre/modules/devtools/toolkit/webconsole/network-monitor.js:579:10
makeInfallible/<@resource://gre/modules/commonjs/toolkit/loader.js -> resource://gre/modules/devtools/DevToolsUtils.js:82:14
Line: 743, column: 8
I can't reproduce this here. I've tried both opt and debug builds, on Mac and Linux to no avail. Anything special about your configuration?
Never mind, I see it when I run browser_markers-gc.js with --run-until-failure.
Assignee: nobody → past
Status: NEW → ASSIGNED
Attachment #8610120 - Flags: review?(vporof)
Attachment #8610120 - Flags: review?(vporof) → review+
"rare case"
https://hg.mozilla.org/mozilla-central/rev/c9bc8e768aa3
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 41
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.