Closed Bug 1167670 Opened 5 years ago Closed 4 years ago

Layout is broken when unplugging an external monitor

Categories

(Core :: Layout, defect)

Unspecified
macOS
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1154125

People

(Reporter: kumar, Unassigned, NeedInfo)

References

Details

(Whiteboard: [Dupe me])

Attachments

(6 files)

On twitter.com, the layout is broken when I unplug an external monitor from my laptop. 

STR:
- plug in an external monitor to a laptop
- make the external monitor your primary window
- load twitter.com and make sure the window is on the external monitor
- unplug the monitor so that all windows move to the laptop window

Expected: I've attached an expected screenshot which I get when I refresh the URL after unplugging.

Application Basics
------------------

Name: Firefox
Version: 40.0a2
Build ID: 20150519004002
Update Channel: aurora
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.10; rv:40.0) Gecko/20100101 Firefox/40.0
Multiprocess Windows: 0/9 (default: false)
Just to be clear, this happens on other sites, not just Twitter. I'll attach some screenshots.
I see the same symptoms in Firefox 38 and 41 on Mac OS X 10.10.4. My external monitor is old and is not Retina.
OS: Unspecified → Mac OS X
MattN, who could we escalate this to?
Flags: needinfo?(MattN+bmo)
BenWa/Milan, this seems vaguely similar to bug 1189565, is someone working on this? Many Mozillians in offices are affected by this when leaving their desks for meetings.
Flags: needinfo?(milan)
Flags: needinfo?(bgirard)
Flags: needinfo?(MattN+bmo)
I believe Markus was looking at this a bit, but I could be wrong.  It is also perhaps a good way to avoid meetings? :)
Flags: needinfo?(mstange)
Flags: needinfo?(milan)
Flags: needinfo?(bgirard)
Is it APZ only? Can you still get the bug if you disable it?
(In reply to Benoit Girard (:BenWa) from comment #14)
> Is it APZ only? 
No.

> Can you still get the bug if you disable it?

Yes. I have this in about:support as I disabled APZ for another bug the other day.

> Asynchronous Pan/Zoom:	none
Tentatively moving this to Layout. Might need to be widget or gfx or something else, but it's definitely not "Fx::General".
Component: General → Layout
Product: Firefox → Core
Does this still occur in latest Nightly? I'm guessing bug 1154125 may have fixed the issues here.
I could not reproduce it following the original steps on today's Nightly.
OK, I'm reasonably sure this is another manifestation of bug 1154125 -- dup'ing.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1154125
I just wanted to say THANK YOU! You made my week. I have tried to replicate the bug after updating to latest nightly. I was unable to reproduce it. It seems to be resolved. (doing the happy dance)
You need to log in before you can comment on or make changes to this bug.