Youtube videos continuously buffer after a few minutes

RESOLVED WORKSFORME

Status

()

Firefox
Untriaged
RESOLVED WORKSFORME
3 years ago
2 years ago

People

(Reporter: Will May, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

3 years ago
After watching a Youtube video with MSE enabled for a few minutes, the video will show that it's buffering but won't actually download any new content. This has occurred in a new profile in a e10s window and in a non-e10s window.

It started occurring a few days ago (Monday?), if it hasn't already been raised then I'll try to track down when it started occurring.

Steps to reproduce
* In about:config, enable 'media.mediasource.enabled', 'media.mediasource.webm.enabled', 'media.fragmented-mp4.exposed' and 'media.fragmented-mp4.ffmpeg.enabled'.
* View Youtube video for 5 - 10 minutes (example: https://www.youtube.com/watch?v=kLdGSfnSAqA)

Actual results
Youtube videos will eventually stop downloading more content and then show that it is buffering but not actually download anything

Expected outcome
Youtube should be downloading more content as it gets to the end of the content already downloaded
(Reporter)

Updated

3 years ago
(Reporter)

Comment 1

3 years ago
Nothing interesting appears in either the browser console, window console or the command line window
(Reporter)

Comment 2

3 years ago
After running mozregression, it appears the issue first appeared on Tuesday within this window: https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=def08fced852&tochange=24a7f0fda98b

Also, the bug occurs reliably on this video (https://www.youtube.com/watch?v=OYzcvTwMZUk) at 1.35; disable annotations, disable autoplay and switch to 1080p. I've been running the video at full screen but I don't believe that to be related to the bug.
(Reporter)

Comment 3

3 years ago
That is Tuesdays nightly build.
So, I've checked on Ubuntu 14.04  with the latest available release build : Version 	42.0 / Build ID 	20151029151421 with flash version: Shockwave Flash 11.2 r202
The video streamed without any issues, nor did I encountered any buffer issues. 

Can you please retry reproducing your issue, preferably on the latest available Firefox release. If the issue is reproducible, please provide the flash version (about:plugins) and ff version (about:support).
Flags: needinfo?(will.j.may)
Due to the lack of information to follow this up, closing this bug as Resolved WFM.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(will.j.may)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.