Closed Bug 116770 Opened 19 years ago Closed 18 years ago

textbox fails to get focus

Categories

(SeaMonkey :: General, defect)

x86
Windows XP
defect
Not set
major

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 82534

People

(Reporter: hachre, Assigned: bryner)

Details

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:0.9.7) Gecko/20011221
BuildID:    2001122106

when i click a textbox with the mouse it sometimes fails to get the focus..
therefore no cursor is blinking and i can't write anything into the textfield...
once this bug happens it applies to all open mozilla windows and also newly
opened windows have the same bug... no matter if its the textbox of the
adressbar or a textbox on the website or in messenger...

you just can't get the focus to any textbox anymore...
this must be dup but i can't find it..

Reproducible: Sometimes
Steps to Reproduce:
1. browse the web
2. use more windows...
3. browse even more
4. close all windows except one
5. leave mozilla unattended for 5 mins
6. try to type something into the adress bar...

it's really hard to reproduce... once I find out how to really reproducte it
i'll post it...

Actual Results:  textboxes in whole mozilla don't get focused anymore
you cant type anything into them anymore...

Expected Results:  focus the textboxes to make the user able to enter something
into them
assigning to bryner (filing bugs like this on Asa as NEW instead of UNCONFIRMED 
is pretty pointless...)
Assignee: asa → bryner
sorry, that was my fault... it didn't want to open it as new... sorry
adding keyword qawanted - this bug is highly visible... there must be a dupe...
I think some other bugs reported in the database about textfields and
focusproblems could depend on this...
Keywords: qawanted
Is this still happening? I've never run into this bug.
Yes, it happens a lot even with 0.9.8 (Linux, Icewm), but I can't find a way to
reproduce it reliably. I will try to find one in the weekend.
Reporter: Is the problem still reproducable with a recent nightly build?

Thanks
It may have something with race conditions, because I often get it while
browsing  (even as of 1.0rc1), and it seems to occur more often with many "open
link in new window", but never experienced it when trying to do something
reproducable. :(

The first click doesn't seem to have any effect, I have to click again in the
URL bar, to be able to type.
Harald: do you only see this after not using Mozilla for a while?
isn't this a dupe of bug 82534 ?
Andrew: no, this may be wrong... it's hard to reproduce... It just happens
sometimes! Well meanwhile I am using Linux and it doesn't happen with any Linux
build I am using... But it still happens very often with RC1 using Windows...
Maybe this is a Windows*-Only problem?
bugzilla@bkor.dhs.org: sorry it took me that long to answer - Yeah it's still
very reproduceable using Windows... I never saw that happen on Linux though.
I have noticed this regularly on websites that have javascript validating what
is typed in but that is a common trick on webpages anyway.  Why is this QA
wanted?  Surely this must happen to some mozilla developers too.  I use focus
follows mouse....the other people that can reproduce this....is that case with
you too?

*** This bug has been marked as a duplicate of 82534 ***
Status: NEW → RESOLVED
Closed: 18 years ago
Resolution: --- → DUPLICATE
If I'm right about duplicate of bug 82534 - please confirm, if I am not right
please reopen...
removing qawanted keyword - since the duplicate of this bug has been found....
Keywords: qawanted
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.