Closed Bug 1167716 Opened 5 years ago Closed 5 years ago

Add-on Doorhanger resizes while downloading Add-on

Categories

(Toolkit :: Themes, defect)

defect
Not set
Points:
2

Tracking

()

RESOLVED FIXED
mozilla41
Iteration:
41.1 - May 25
Tracking Status
firefox40 + fixed
firefox41 + fixed

People

(Reporter: designakt, Assigned: dao)

References

Details

(Keywords: regression)

Attachments

(2 files, 1 obsolete file)

Due to the string showing the progress of the download the doorhanger width is changing. This change causes unnecessary flickering and movement in the UI and should therefore be prevented. (It also moves the buttons around which makes it rather hard to cancel the install…)
Can we remove the download speed and only show it in tool-tip as in the downloads doorhanger.
If this is not enough we could abbreviate seconds to sec but I assume this might be difficult due to localization.
Flags: needinfo?(dtownsend)
Yeah that's not great. Dao, any chance you can take this?
Blocks: 1149654
Flags: needinfo?(dtownsend) → needinfo?(dao)
I'll take a look. Could be a regression from bug 630210.
Assignee: nobody → dao
Flags: needinfo?(dao)
Blocks: 630210
Component: General → Themes
Flags: qe-verify-
Flags: firefox-backlog+
Keywords: regression
Product: Firefox → Toolkit
Iteration: --- → 41.1 - May 25
Points: --- → 2
Attached patch patch (obsolete) — Splinter Review
Bug 630210 moved popup-notification-description deeper into the panel structure such that the max-width we set on it doesn't constrain the size of all content as intended.
Attachment #8609606 - Flags: review?(dtownsend)
Adding a tracking flag for firefox40 and firefox41 as this is a regression in a very common user scenario.
Attachment #8609606 - Flags: review?(dtownsend) → review+
Backed out in https://hg.mozilla.org/integration/fx-team/rev/0d2eaa2b77ac - I'm sure there must be some sort of explanation for this, but, it made a11y/accessible/tests/mochitest/states/test_link.html time out 100% of the time on 10.6 only.
Alexander, any idea why this patch could cause a11y/accessible/tests/mochitest/states/test_link.html to time out on 10.6? Do you think this is a real bug or more likely flaky testing infrastructure? Is disabling the test on 10.6 an option?
Flags: needinfo?(surkov.alexander)
Oh, I forgot about screenshots - http://mozilla-releng-blobs.s3.amazonaws.com/blobs/fx-team/sha512/9c54d66b6014662f16e59938d99380f0893fcf7b94a3753ed42f22964802c41a37f88ae7cb7bd82fb7cce643d673b8750f4300e42e8eecd713e798e14229e1fb doesn't explain why 10.6-only, or who put that notification up, or why the "mochitests" addon is corrupted, but I bet it explains why test_link.html times out, because it can't get to its link underneath that notification.
Oh, hm, I guess I should file a bug about that, and in the meantime I'll just land this with 25em instead of 24em so we don't hit that problem here.
Flags: needinfo?(surkov.alexander)
Attached patch patchSplinter Review
Attachment #8609606 - Attachment is obsolete: true
Filed bug 1167937 on the interfering popup notification.
https://hg.mozilla.org/mozilla-central/rev/301df7d05cf4
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla41
Comment on attachment 8609789 [details] [diff] [review]
patch

Approval Request Comment
[Feature/regressing bug #]: bug 630210
[User impact if declined]: see comment 0
[Describe test coverage new/current, TreeHerder]: no test coverage for this behavior
[Risks and why]: pretty straightforward fix, low risk
[String/UUID change made/needed]: none
Attachment #8609789 - Flags: approval-mozilla-aurora?
Comment on attachment 8609789 [details] [diff] [review]
patch

Should be safe, taking it.
Attachment #8609789 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Duplicate of this bug: 1167199
You need to log in before you can comment on or make changes to this bug.