Clearing download complete notifications crashes Firefox

RESOLVED DUPLICATE of bug 1075476

Status

()

Firefox for Android
Download Manager
--
major
RESOLVED DUPLICATE of bug 1075476
3 years ago
3 years ago

People

(Reporter: Nicolae Albu, Unassigned)

Tracking

38 Branch
ARM
Android
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:36.0) Gecko/20100101 Firefox/36.0
Build ID: 20150320202338

Steps to reproduce:

0.1. This is reproducible on low RAM devices. Mine which crashes has 717 MB (total RAM).
0.2. I can't reproduce this on Android emulator because the download notifications automatically dismiss after completion. I don't know if this is a Firefox feature or stock Android. But on my Samsung phone (Trend Plus S7580 4.2.2), they don't auto dismiss, so I can reproduce it.
0.3. This is just a "synthetic" way of reproducing the crash. In real world, it happens with multiple images and a fairly loaded page.
1. Open Firefox.
2. Go to https://wallpaperscraft.com/download/black_white_line_silver_186/3840x2160.
3. Long tap, then save image.
4. Do this 40 times (so you will have 40 notifications).
5. Pull down the notification bar.
6. Press the "Clear all" button.
7. Wait.


Actual results:

Firefox crashes. Probably a OOM. It doesn't even bring me to the crash reporter.


Expected results:

Firefox should not crash when clearing download complete notifications.
(Reporter)

Updated

3 years ago
Severity: normal → major
OS: Unspecified → Android
Hardware: Unspecified → ARM
See Also: → bug 1075476
(Reporter)

Comment 1

3 years ago
I think this is related to bug 1075476 - maybe the cause is the same, but the effects are different or combined.
Yep.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1075476
You need to log in before you can comment on or make changes to this bug.