hotizontal scrolling required with default browser size (not required in IE5.5, Netscape 4.79)

RESOLVED FIXED in Future

Status

()

Core
Layout
RESOLVED FIXED
16 years ago
16 years ago

People

(Reporter: Bharat, Assigned: Marc Attinasi)

Tracking

Trunk
Future
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:0.9.7) Gecko/20011221
BuildID:    2001122106

When the above URL is viewed in Mozilla 0.9.7, the width of the page is
larger than the default widtch of the browser window, with the result
that horizontal scrollbars appear. This does not happen with IE5.5 or
Netscape 4.79. It is a pain to scroll the window horizontally to view the
entire content.

If I increase the size of the browser window, there is a cutoff point reached
where the page layout width becomes equal/less than the browser window width,
and the horizontal scrollbars disappear.

Note that this did not used to happen with some earlier Mozilla
builds (I'm not sure of the version where I first noticed this, but
it could have been 0.9.5 or later).

Reproducible: Always
Steps to Reproduce:
1. Go to above URL
2.
3.

Actual Results:  Horizontal scrollbars appear.

Expected Results:  They shouldn't appear? Unfortunately, I'm not sure how to
dissect the page to find out if it's a bug in Mozilla, or that bad HTML on that
page is being interpreted wrongly (from a standards point of view) by
IE/Netscape.
If you:

1)  Close the sidebar
2)  Make the Mozilla window the size of the IE window

Do you see the scrollbars? If so, are IE and Mozilla using the same font size?  
Are there any obvious visual differences that contribute to the different 
widths?
(Reporter)

Comment 2

16 years ago
I did *not* have the sidebar open. Also the fonts in IE and mozilla are more
or less the same. There are some visual differences between them though.
I'm going to upload two attachments:
1. Screenshot of IE(fully maximized) showing the above page
2. Screenshot of Mozilla (fully maximized) showing the above page

Both the screenshots will show just the layout portion, and you should be able to
see the difference. BTW, the attachments are in JPG format set for small file
size, so the quality will not be that good.
(Reporter)

Comment 3

16 years ago
Created attachment 62744 [details]
Screenshot of IE showing the above page

Screenshot of IE (layout portion only) fully maximized showing the above page.
(Reporter)

Comment 4

16 years ago
Created attachment 62745 [details]
Screenshot of Mozilla (layout portion only) fully maximized showing the above page
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 5

16 years ago
WFM, build 2001-12-26-03 (trunk) on Windows 98 SE.
(Reporter)

Comment 6

16 years ago
I downloaded the latest nightly (Build ID: 2001123103), and the problem is
still there.

After the main Times Of India banner at the top of the page, the next section of
the page has the news layout in 4 columns. In Mozilla, there is a big gap between
the 3rd and 4th columns, which doesn't appear in IE (today I see some bizarre
layout behaviour in Netscape 4.79 as well).

Updated

16 years ago
Target Milestone: --- → Future
(Reporter)

Comment 7

16 years ago
I tried this again using Mozilla RC1.0, and the problem seems to have gone away.
Marking FIXED.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.